Closed Bug 1730151 Opened 11 months ago Closed 11 months ago

Asked for password, but doesn't ask for username if username not provided in the prefs - "message could not be sent ... for an unknown reason"

Categories

(MailNews Core :: Networking: SMTP, defect)

Thunderbird 91
defect
Not set
normal

Tracking

(thunderbird_esr91+ fixed, thunderbird93+ fixed)

RESOLVED FIXED
94 Branch
Tracking Status
thunderbird_esr91 + fixed
thunderbird93 + fixed

People

(Reporter: ilmari.lauhakangas, Assigned: rnons)

References

(Blocks 1 open bug)

Details

(Keywords: reproducible)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #203099 +++

  1. Configure a SMTP server, check "Use name and password" but don't enter a
    Username.
  2. Send a mail through this server.

Actual Results:
It asks for password but not for username and fails sending

Expected Results:
It asks for username and password and sending succeeds

Re-tested with 91.1.0 on Arch Linux and the same problem remains.

Blocks: tb91found
Assignee: nobody → remotenonsense
Status: NEW → ASSIGNED
Target Milestone: --- → 94 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/1964500808cc
Ask for username if not set in the SMTP auth prompt. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED

Comment on attachment 9240856 [details]
Bug 1730151 - Ask for username if not set in the SMTP auth prompt. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): long time ago
User impact if declined: if SMTP username is empty and auth required, the auth prompt only ask for password
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9240856 - Flags: approval-comm-esr91?
Attachment #9240856 - Flags: approval-comm-beta?

Comment on attachment 9240856 [details]
Bug 1730151 - Ask for username if not set in the SMTP auth prompt. r=mkmelin

[Triage Comment]
Approved for beta

Attachment #9240856 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9240856 [details]
Bug 1730151 - Ask for username if not set in the SMTP auth prompt. r=mkmelin

[Triage Comment]
Approved for esr91

Attachment #9240856 - Flags: approval-comm-esr91? → approval-comm-esr91+
You need to log in before you can comment on or make changes to this bug.