Closed Bug 1730388 Opened 11 months ago Closed 10 months ago

Crash in [@ memcpy | icalvalue_get_recur]

Categories

(Calendar :: General, defect)

Thunderbird 91
Unspecified
All
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 1733309

People

(Reporter: wsmwk, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Crash Data

#15 crash for 91.0.3. Five of 7 crashes sampled have Avast installed. However, this one does not.

Crash report: https://crash-stats.mozilla.org/report/index/9544a9f4-523f-4f0b-8fdf-761fb0210908

Reason: EXCEPTION_ACCESS_VIOLATION_READ

Top 10 frames of crashing thread:

0 vcruntime140.dll memcpy f:\dd\vctools\crt\vcruntime\src\string\amd64\memcpy.asm:386
1 xul.dll icalvalue_get_recur comm/calendar/libical/src/libical/icalderivedvalue.c:871
2 xul.dll icalproperty_get_rrule comm/calendar/libical/src/libical/icalderivedproperty.c:2598
3 xul.dll icaltimezone_ensure_coverage comm/calendar/libical/src/libical/icaltimezone.c:473
4 xul.dll icaltimezone_get_utc_offset comm/calendar/libical/src/libical/icaltimezone.c:804
5 xul.dll icaltimezone_convert_time comm/calendar/libical/src/libical/icaltimezone.c:759
6 xul.dll icaltime_convert_to_zone comm/calendar/libical/src/libical/icaltime.c:1081
7 xul.dll static calDateTime::IcaltimeToPRTime comm/calendar/base/backend/libical/calDateTime.cpp:482
8 xul.dll calDateTime::FromIcalTime comm/calendar/base/backend/libical/calDateTime.cpp:466
9 xul.dll static calIcalProperty::getDatetime_ comm/calendar/base/backend/libical/calICSService.cpp:422

Mac equivalent? icalvalue_get_recur bp-134e1f21-ab2c-488e-9d48-b66b90210907

Blocks: tb91found

Bug 1733309 fixed this I think. Crashing line is a few off, but should be the same.

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1733309

Confirmed, crash is gone in 91.2.0

Status: RESOLVED → VERIFIED
Crash Signature: [@ memcpy | icalvalue_get_recur] → [@ memcpy | icalvalue_get_recur] [@ icalvalue_get_recur]
OS: Windows 10 → All
Product: Thunderbird → Calendar
You need to log in before you can comment on or make changes to this bug.