Drop down <option> in form does not work with CSS

VERIFIED DUPLICATE of bug 163503

Status

()

VERIFIED DUPLICATE of bug 163503
16 years ago
14 years ago

People

(Reporter: jss, Assigned: john)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2a) Gecko/20020910

The above test was generated from the page
http://www.admin.cam.ac.uk/offices/accommodation/tenants/tenant.cgi

On this test page the drop down box on the form does not work. It turns red when
clicked and closes up again.

The page contains CSS. With this CSS I get this problem, without it, it goes away.

I can't see why the CSS is causing this problem, but maybe I misunderstand it.



Reproducible: Always

Steps to Reproduce:
1. Go to page
2. Click drop down box
3.

Actual Results:  
Drop down box closes immediately.


Expected Results:  
Drop down box should stay open to select option

CSS is:
<style type="text/css">
 body {
  background-color: #ffffff;
  color: #000000;
 }
 :link { color: #0000ff }
 :visited { color: #990066 }
 :active { color: #ff0000 }
 span.c3 {font-size: 80%}
 h1.c2 {text-align: left}
 div.c1 {text-align: right}
</style>

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 163503 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.