Closed Bug 1730619 Opened 1 month ago Closed 1 month ago

Perma [Tier 2] package> mozmake[5]: *** [z:/build/build/src/toolkit/mozapps/installer/packager.mk:34: stage-package] Error 1 | Assertions.h:157:1: warning: function declared 'noreturn' should not return [-Winvalid-noreturn], err: false

Categories

(Firefox Build System :: General, defect, P5)

defect

Tracking

(firefox-esr78 unaffected, firefox-esr91 unaffected, firefox92 unaffected, firefox93 unaffected, firefox94 fixed)

RESOLVED FIXED
94 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox92 --- unaffected
firefox93 --- unaffected
firefox94 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: mhentges)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: smolnar [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=351405582&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/IW4ZyUweQpSluNypvWzpmA/runs/0/artifacts/public/logs/live_backing.log


INFO -  [swgl 0.1.0] running: "z:/build/fetches/sccache/sccache.exe" "z:/build/fetches/clang/bin/clang.exe
WARNING -  [style 0.0.1] z:/build/workspace/obj-build/dist\include\mozilla/Assertions.h:157:1: warning: function declared 'noreturn' should not return [-Winvalid-noreturn], err: false
[task 2021-09-13T18:30:41.804Z] 18:30:41  WARNING -  [style 0.0.1] z:/build/workspace/obj-build/dist\include\mozilla/cxxalloc.h:32:1: warning: replacement function 'operator new' cannot be declared 'inline' [-Winline-new-delete], err: false
[task 2021-09-13T18:30:41.804Z] 18:30:41  WARNING -  [style 0.0.1] z:/build/workspace/obj-build/dist\include\mozilla/cxxalloc.h:36:1: warning: replacement function 'operator new' cannot be declared 'inline' [-Winline-new-delete], err: false
[task 2021-09-13T18:30:41.805Z] 18:30:41  WARNING -  [style 0.0.1] z:/build/workspace/obj-build/dist\include\mozilla/cxxalloc.h:41:1: warning: replacement function 'operator new[]' cannot be declared 'inline' [-Winline-new-delete], err: false
[task 2021-09-13T18:30:41.805Z] 18:30:41  WARNING -  [style 0.0.1] z:/build/workspace/obj-build/dist\include\mozilla/cxxalloc.h:45:1: warning: replacement function 'operator new[]' cannot be declared 'inline' [-Winline-new-delete], err: false
[task 2021-09-13T18:30:41.806Z] 18:30:41  WARNING -  [style 0.0.1] z:/build/workspace/obj-build/dist\include\mozilla/cxxalloc.h:50:1: warning: replacement function 'operator delete' cannot be declared 'inline' [-Winline-new-delete], err: false
[task 2021-09-13T18:30:41.806Z] 18:30:41  WARNING -  [style 0.0.1] z:/build/workspace/obj-build/dist\include\mozilla/cxxalloc.h:54:1: warning: replacement function 'operator delete' cannot be declared 'inline' [-Winline-new-delete], err: false
[task 2021-09-13T18:30:41.807Z] 18:30:41  WARNING -  [style 0.0.1] z:/build/workspace/obj-build/dist\include\mozilla/cxxalloc.h:59:1: warning: replacement function 'operator delete[]' cannot be declared 'inline' [-Winline-new-delete], err: false
[task 2021-09-13T18:30:41.807Z] 18:30:41  WARNING -  [style 0.0.1] z:/build/workspace/obj-build/dist\include\mozilla/cxxalloc.h:63:1: warning: replacement function 'operator delete[]' cannot be declared 'inline' [-Winline-new-delete], err: false
[task 2021-09-13T18:30:41.808Z] 18:30:41  WARNING -  [style 0.0.1] z:/build/workspace/obj-build/dist\include\nsTArray.h:3171:19: warning: 'iterator<std::output_iterator_tag, void, void, void, void>' is deprecated: warning STL4015: The std::iterator class template (used as a base class to provide typedefs) is deprecated in C++17. (The <iterator> header is NOT deprecated.) The C++ Standard has never required user-defined iterators to derive from std::iterator. To fix this warning, stop deriving from std::iterator and start providing publicly accessible typedefs named iterator_category, value_type, difference_type, pointer, and reference. Note that value_type is required to be non-const, even for constant iterators. You can define _SILENCE_CXX17_ITERATOR_BASE_CLASS_DEPRECATION_WARNING or _SILENCE_ALL_CXX17_DEPRECATION_WARNINGS to acknowledge that you have received this warning. [-Wdeprecated-declarations], err: false
[task 2021-09-13T18:30:41.809Z] 18:30:41  WARNING -  [style 0.0.1] z:/build/workspace/obj-build/dist\include\nsGkAtoms.h:118:39: warning: offset of on non-standard-layout type 'mozilla::detail::GkAtoms' [-Winvalid-offsetof], err: false
[task 2021-09-13T18:30:41.809Z] 18:30:41  WARNING -  [style 0.0.1] z:/build/workspace/obj-build/dist\include\js/HeapAPI.h:251:38: warning: offset of on non-standard-layout type 'js::gc::TenuredChunkBase' [-Winvalid-offsetof], err: false
[task 2021-09-13T18:30:41.810Z] 18:30:41  WARNING -  [style 0.0.1] z:/build/workspace/obj-build/dist\include\js/Proxy.h:211:43: warning: offset of on non-standard-layout type 'js::BaseProxyHandler' [-Winvalid-offsetof], err: false
[task 2021-09-13T18:30:41.810Z] 18:30:41     INFO -  [glslopt 0.1.9] exit code: 0
<...>
z:/build/workspace/obj-build/_virtualenvs/build/Scripts/python.exe z:/build/build/src/mach build-backend -b ChromeMap
[task 2021-09-13T19:06:23.359Z] 19:06:23     INFO -  package>  0:02.33 z:/build/workspace/obj-build\_virtualenvs\common\Scripts\python.exe z:/build/workspace/obj-build\config.status --backend ChromeMap
[task 2021-09-13T19:06:23.359Z] 19:06:23     INFO -  package> Error running mach:
[task 2021-09-13T19:06:23.359Z] 19:06:23     INFO -  package>
[task 2021-09-13T19:06:23.359Z] 19:06:23     INFO -  package>     ['build-backend', '-b', 'ChromeMap']
[task 2021-09-13T19:06:23.360Z] 19:06:23     INFO -  package>
[task 2021-09-13T19:06:23.360Z] 19:06:23     INFO -  package> The error occurred in code that was called by the mach command. This is either
[task 2021-09-13T19:06:23.360Z] 19:06:23     INFO -  package> a bug in the called code itself or in the way that mach is calling it.
[task 2021-09-13T19:06:23.361Z] 19:06:23     INFO -  package> You can invoke |./mach busted| to check if this issue is already on file. If it
[task 2021-09-13T19:06:23.361Z] 19:06:23     INFO -  package> isn't, please use |./mach busted file build-backend| to report it. If |./mach busted| is
[task 2021-09-13T19:06:23.361Z] 19:06:23     INFO -  package> misbehaving, you can also inspect the dependencies of bug 1543241.
[task 2021-09-13T19:06:23.361Z] 19:06:23     INFO -  package>
[task 2021-09-13T19:06:23.362Z] 19:06:23     INFO -  package> If filing a bug, please include the full output of mach, including this error
[task 2021-09-13T19:06:23.362Z] 19:06:23     INFO -  package> message.
[task 2021-09-13T19:06:23.362Z] 19:06:23     INFO -  package>
[task 2021-09-13T19:06:23.362Z] 19:06:23     INFO -  package> The details of the failure are as follows:
[task 2021-09-13T19:06:23.363Z] 19:06:23     INFO -  package>
[task 2021-09-13T19:06:23.363Z] 19:06:23     INFO -  package> FileNotFoundError: [WinError 2] The system cannot find the file specified
[task 2021-09-13T19:06:23.363Z] 19:06:23     INFO -  package>
[task 2021-09-13T19:06:23.363Z] 19:06:23     INFO -  package>   File "z:\build\build\src\python/mozbuild/mozbuild/build_commands.py", line 310, in build_backend
[task 2021-09-13T19:06:23.364Z] 19:06:23     INFO -  package>     args=args, pass_thru=True, ensure_exit_code=False
[task 2021-09-13T19:06:23.364Z] 19:06:23     INFO -  package>   File "z:\build\build\src\python/mozbuild\mozbuild\base.py", line 853, in _run_command_in_objdir
[task 2021-09-13T19:06:23.364Z] 19:06:23     INFO -  package>     return self.run_process(cwd=self.topobjdir, **args)
[task 2021-09-13T19:06:23.364Z] 19:06:23     INFO -  package>   File "z:\build\build\src\python/mach\mach\mixin\process.py", line 130, in run_process
[task 2021-09-13T19:06:23.365Z] 19:06:23     INFO -  package>     proc = subprocess.Popen(args, cwd=cwd, env=use_env, close_fds=False)
[task 2021-09-13T19:06:23.365Z] 19:06:23     INFO -  package>   File "c:\mozilla-build\python3\lib\subprocess.py", line 709, in __init__
[task 2021-09-13T19:06:23.365Z] 19:06:23     INFO -  package>     restore_signals, start_new_session)
[task 2021-09-13T19:06:23.366Z] 19:06:23     INFO -  package>   File "c:\mozilla-build\python3\lib\subprocess.py", line 997, in _execute_child
[task 2021-09-13T19:06:23.366Z] 19:06:23     INFO -  package>     startupinfo)
[task 2021-09-13T19:06:23.366Z] 19:06:23    ERROR -  package> mozmake[5]: *** [z:/build/build/src/toolkit/mozapps/installer/packager.mk:34: stage-package] Error 1
[task 2021-09-13T19:06:23.366Z] 19:06:23     INFO -  package> mozmake[5]: Leaving directory 'z:/build/workspace/obj-build/browser/installer'
[task 2021-09-13T19:06:23.367Z] 19:06:23    ERROR -  package> mozmake[4]: *** [z:/build/build/src/toolkit/mozapps/installer/packager.mk:111: make-package] Error 2
[task 2021-09-13T19:06:23.367Z] 19:06:23    ERROR -  package> mozmake[3]: *** [z:/build/build/src/config/rules.mk:358: default] Error 2
[task 2021-09-13T19:06:23.367Z] 19:06:23    ERROR -  package> mozmake[2]: *** [z:/build/build/src/browser/build.mk:6: package] Error 2
[task 2021-09-13T19:06:23.368Z] 19:06:23    ERROR -  mozmake[1]: *** [z:/build/build/src/build/moz-automation.mk:110: automation/package] Error 2
[task 2021-09-13T19:06:23.368Z] 19:06:23     INFO -  mozmake[1]: *** Waiting for unfinished jobs....
[task 2021-09-13T19:07:12.416Z] 19:07:12     INFO -  package-tests> mozmake[2]: Entering directory 'z:/build/workspace/obj-build'

@Mitchell, these build bustages seems to start from your push but I can't figure out from which bug.
Could you take a look?
Thanks

Flags: needinfo?(mhentges)

Pretty sure it's because of this patch that splits the build virtualenv from the common virtualenv. Accordingly, the failure would be caused by a leftover incorrect usage of the common virtualenv when the build virtualenv is correct.

Flags: needinfo?(mhentges)
Regressed by: 1717104

The build-backend command uses
command_context.virtualenv_manager, which by default
is associated with the "common" virtualenv.

This patch aligns virtualenv_manager with the "build"
virtualenv as set up within init.configure.

Assignee: nobody → mhentges
Status: NEW → ASSIGNED
Pushed by mhentges@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3ad99bae35e2
Associate build commands with "build" venv r=ahal
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch
You need to log in before you can comment on or make changes to this bug.