Closed Bug 173077 Opened 20 years ago Closed 14 years ago

print preview of nothing tried to create a window

Categories

(MailNews Core :: Printing, defect, P1)

x86
Windows 2000
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME
Future

People

(Reporter: timeless, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

doron tested this using his untarnished mailnews client. 

the steps:
1. open mailnews to a folder
2. scroll to the very end of the thread pane and size the pane so that you can
see some whitespace
3. select a message in the thread pane
4. ctrl-click it to deselect it (problems start here)
5. right click whitespace in the threadpane (be sure not to click on a row that
has a message)
5' print preview was enabled - bug 173074
6. click print preview
6' nothing really happens
7. click the window menu
7' see a blank numbered window entry

What should we do? well, i'd kind of like print preview not to create bogus windows.
(yes these aren't really valid dependencies, but if you fix things one way the
problems will disappear...)
Assignee: dcone → rods
Blocks: 173079
Depends on: 173074
Summary: print preview is enabled in the context menu for whitespace → print preview of nothing tried to create a window
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → Future
Attached patch first try at fixSplinter Review
This patch works -- when you select Print Preview with no messages selected, no
bogus windows are created, and further, no JS errors or warnings are produced
(that is, if bug 191158 is fixed). But the patch seems like a hack. Maybe we
should just fix bug 173074 and be done with it.
Product: MailNews → Core
is this still a problem now that bug 173074 is fixed?
Assignee: rods → nobody
Status: ASSIGNED → NEW
QA Contact: esther
QA Contact: printing
Product: Core → MailNews Core
Unable to reproduce in 2.0.0.16 on WinXP (Print Preview is disabled in the context menu), so I'm guessing it was fixed as per the previous comment.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
v. WFM on trunk thunderbird
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.