Inbox (IMAP?) date sorting is incorrect when mail arrives

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Peter, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
using mozilla 2002-10-05, win98:

Inbox (IMAP?) date sorting is incorrect when mail arrives.

I have my inbox sorted by most recent mail first (date-descending).

When mail arrives, usually the oldest arriving mail is displayed below a mail i
had received previously - even though the new mail is younger than the
previously received mail, and therefore should be *above* the previously
received mail.

todays mail     31.10.2525
todays mail     30.10.2525
todays mail     29.10.2525
todays mail     28.10.2525
yesterdays mail 01.09.2525
todays mail     27.10.2525 <-- wrong sort location

Oddly, sorting by another collumn, and then resorting by date then sorts
correctly - but that is not an accepable solution.

Today, *four* mails went below an older mail (perhaps because I left my PC
unattended for a while and Mozilla checked for new mail *four* times while I was
gone?) - see screenshot below.
(Reporter)

Comment 1

16 years ago
Created attachment 102017 [details]
Screenshot showing how incoming mails are incorrctly sorted in the inbox.

Updated

16 years ago
QA Contact: olgam → laurel

Comment 2

16 years ago
Peter Lairo, are you still seeing this bug?  It appears to be working as you 
expect in 1.3 & 1.4b -- currently arriving mails are at the top of the list if 
sorted in recent-first order.
(Reporter)

Comment 3

16 years ago
This bug no longer occurs for me. Resolving WFM. 

Thanks for pointing it out Mike.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.