Closed Bug 1730876 Opened 3 months ago Closed 2 months ago

Sponsored Suggestions are not displayed for a keyword after it was clicked twice

Categories

(Firefox :: Address Bar, defect, P1)

Desktop
All
defect
Points:
3

Tracking

()

VERIFIED FIXED
94 Branch
Iteration:
94.1 - Sep 6 - Sept 19
Tracking Status
firefox92 --- verified
firefox93 --- verified
firefox94 --- verified

People

(Reporter: mheres, Assigned: adw)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image hublot 2.gif

[Affected Versions]:

  • FIrefox Beta 93.0b5 (Build ID: 20210914185637)
  • Firefox Nightly 94.0a1 (Build ID: 20210915092453)

[Affected Platforms]:

  • Windows 10
  • Linux Mint 20
  • macOS 11.1

[Prerequisites]:

  • Have Firefox en-US ver 93 installed and opened.
  • Be in the US (or use a VPN / set “browser.search.region” to “US”)

[Steps to reproduce]:

  1. Focus the awesomebar and type a keyword (e.g. “hublot “).
  2. Click the sponsored Firefox Suggest result.
  3. Open a new tab and repeat steps 1 and 2.
  4. Open a new tab and focus the awesomebar.
  5. Type the keyword again (i.e. “hublot “) and observe the suggestions displayed.

[Expected result]:

  • The sponsored suggestion is displayed when a keyword is used.

[Actual result]:

  • The sponsored suggestion is displayed twice and then it is no longer displayed - only the history version is displayed.

[Notes]:

  • Attached is a screen recording of the issue.

Nice catch, thank you Maria.

The muxer is de-deduping (removing) the Fx Suggest suggestion because its URL is the same as the one from history.

Assignee: nobody → adw
Status: NEW → ASSIGNED
Iteration: --- → 94.1 - Sep 6 - Sept 19
Points: --- → 3
Priority: -- → P1
Blocks: 1730878

This makes a couple of changes:

  • Never discard suggestedIndex results. At some point we may want to revisit,
    but right now in all our use cases for suggestedIndex, we should never discard
    them.
  • Discard non-suggestedIndex URL results whose URLs dupe the URLs of
    suggestedIndex results or whose URLs have a lower prefix rank.

The first change by itself fixes the bug, but without the second change, we'll
still show the eBay history result above the eBay Firefox Suggest result, which
I don't think is what we want. We only want to show the Firefox Suggest one.

Keep in mind that the results in this case have the same URLs, same prefixes.
However, when a non-suggestedIndex result has a higher prefix rank, I think we
should not discard it. In that case we should show both the suggestedIndex
result with its lower prefix rank and the other result with its higher rank.

Duplicate of this bug: 1730878
Attachment #9241472 - Attachment description: Bug 1730876 - Never discard suggestedIndex results and dedupe non-suggestedIndex results with a lower or same prefix rank. → Bug 1730876 - Never discard quick suggest results and dedupe other URL results with a lower or same prefix rank.
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/54b20adae193
Never discard quick suggest results and dedupe other URL results with a lower or same prefix rank. r=mak
Flags: qe-verify+
Flags: in-testsuite+
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch
  • I have verified this issue using the latest Nightly 94.0a1 (Build ID: 20210917093507) build on Windows 10 x64, macOS 11.6 and Linux Ubuntu 20.04 x64.
  • The sponsored suggestions are displayed when typing the keyword in the Address Bar, even if they were previously clicked several times.
Status: RESOLVED → VERIFIED

Comment on attachment 9241472 [details]
Bug 1730876 - Never discard quick suggest results and dedupe other URL results with a lower or same prefix rank.

Beta/Release Uplift Approval Request

  • User impact if declined: Needed for important Firefox Suggest rollouts on 93 and 92
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Please see comment 0
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is a small fix that only applies to Firefox Suggest suggestions.
  • String changes made/needed:
Attachment #9241472 - Flags: approval-mozilla-release?
Attachment #9241472 - Flags: approval-mozilla-beta?

Comment on attachment 9241472 [details]
Bug 1730876 - Never discard quick suggest results and dedupe other URL results with a lower or same prefix rank.

Approved for 93.0b7.

Attachment #9241472 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]
  • I have verified this issue using the latest Beta 93.0b7 (Build ID: 20210919190049) build on Windows 10 x64, macOS 11.6 and Linux Ubuntu 20.04 x64.
  • The sponsored suggestions are displayed when typing the keyword in the Address Bar, even if they were previously clicked several times.

Comment on attachment 9241472 [details]
Bug 1730876 - Never discard quick suggest results and dedupe other URL results with a lower or same prefix rank.

Approved for 92.0.1.

Attachment #9241472 - Flags: approval-mozilla-release? → approval-mozilla-release+
  • I have verified this issue using the Candidate 92.0.1 build (Build ID: 20210920202613) on Windows 10 x64, macOS 10.15.7 and Linux Ubuntu 20.04 x64.

  • The sponsored suggestions are displayed when typing the keyword in the Address Bar, even if they were previously clicked several times.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.