Closed Bug 1731104 Opened 1 month ago Closed 1 month ago

The Privacy pane is not focused after choosing to customize settings from the modal button if other than Privacy pane was already opened in an existing tab

Categories

(Firefox :: Address Bar, defect, P1)

Desktop
All
defect
Points:
1

Tracking

()

VERIFIED FIXED
94 Branch
Iteration:
94.1 - Sep 6 - Sept 19
Tracking Status
firefox92 --- verified
firefox93 --- verified
firefox94 --- verified

People

(Reporter: cfat, Assigned: adw)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Attached image preferences.gif

[Affected versions]:

  • Firefox Beta 93.0b5 (Build ID: 20210914185637)
  • Firefox Nightly 94.0a1 (Build ID: 20210916125444)

[Affected Platforms]:

  • Windows 10 x64;
  • macOS 10.15.7;
  • Linux Ubuntu 20.04 x64;

[Prerequisites]:

  • Have the Session restore enabled.
  • Have the “about:preferences” page displayed, with other than Privacy pane displayed (e.g. “Home”).
  • Set the region to US by running the following snippet in the Browser Console:
    (function(){
    let home = "US";
    Cu.import("resource://gre/modules/Region.jsm");
    Region._setHomeRegion(home, false);
    console.log(Home region is now:, Region.home);
    })();

[Steps to reproduce]:

  1. Open the Firefox browser.
  2. Set the following preferences:
    browser.urlbar.quicksuggest.enabled: true
    browser.urlbar.quicksuggest.scenario: online
    browser.urlbar.quicksuggest.shouldShowOnboardingDialog: true
    browser.urlbar.suggest.quicksuggest: false
    browser.urlbar.suggest.quicksuggest.sponsored: false
  3. Restart the browser.
  4. Click the “Customize in settings” button from the Onboarding modal.
  5. Observe what happens next.

[Expected result]:

  • The user is redirected to the already opened “about:preferences” page, with the Privacy pane in focus, Address Bar - Firefox Suggest section is highlighted.

[Actual result]:

  • The user is redirected to the already opened “about:preferences” page, with the previously selected pane in focus.

[Notes]:

  • The following errors are displayed in the Browser Console when clicking the “Customize in settings” button from the Onboarding modal:
    Nightly
    [bug 1345098] Lazy browser prematurely inserted via 'loadURI' property access: getter@chrome://browser/content/tabbrowser.js:2271:39 switchIfURIInWindow@chrome://browser/content/browser.js:8620:11 switchToTabHavingURI@chrome://browser/content/browser.js:8643:26 openPreferences@chrome://browser/content/utilityOverlay.js:1045:20 maybeShowOnboardingDialog@resource:///modules/UrlbarQuickSuggest.jsm:265:11

Uncaught (in promise) TypeError: can't access property "readyState", browser.contentDocument is null openPreferences chrome://browser/content/utilityOverlay.js:1064 maybeShowOnboardingDialog resource:///modules/UrlbarQuickSuggest.jsm:265l

Beta
TypeError: browser.contentWindow.gotoPref is not a functionutilityOverlay.js:1064:27

  • Attached is a screen recording of the issue.
Assignee: nobody → adw
Status: NEW → ASSIGNED
Iteration: --- → 94.1 - Sep 6 - Sept 19
Points: --- → 1
Priority: -- → P1
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3c56156ed873
Null check browser.contentDocument when highlighting a section in a lazy about:preferences tab. r=dao
Flags: qe-verify+
Flags: in-testsuite-

Carmen, you may still see the first error (the one with "[bug 1345098] Lazy browser prematurely inserted via 'loadURI' property access"), but you shouldn't see the second error ("TypeError: browser.contentWindow.gotoPref"). The first error isn't important AFAICT and shouldn't prevent focusing the privacy pane or highlighting the address bar section. Hopefully I'm not wrong this time...

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch
  • I have verified this issue using the latest Nightly 94.0a1 (Build ID: 20210917093507) build, US region, on Windows 10 x64, macOS 11.6, and Linux Ubuntu 20.04 x64.
  • The user is correctly redirected to the Privacy pane, with the Address Bar - Firefox Suggest section highlighted, in the existing tab.
  • Also you were right, the second error is not displayed anymore in the Browser Console.
Status: RESOLVED → VERIFIED

Approval Request Comment
[Feature/Bug causing the regression]: Firefox Suggest offline/online rollouts
[User impact if declined]: Needed for important rollouts on 93 and 92
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: Please see comment 0
[List of other uplifts needed for the feature/fix]: See uplift coordination spreadsheet
[Is the change risky?]: Low risk relative to other uplifts needed in the patch stack
[Why is the change risky/not risky?]: This patch only adds a null check for a specific property. Note that this patch is slightly different from the one that landed on m-c but only because another bug landed on m-c after this one. The core fix is the same. I've manually verified the fix on a local 93/beta build.
[String changes made/needed]:

Attachment #9241851 - Flags: approval-mozilla-release?
Attachment #9241851 - Flags: approval-mozilla-beta?

Comment on attachment 9241851 [details] [diff] [review]
93/beta & 92/release patch

Approved for 93.0b7.

Attachment #9241851 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]
  • I have verified this issue using the latest Beta 93.0b7 (Build ID: 20210919190049) build on Windows 10 x64, macOS 11.6 and Linux Ubuntu 20.04 x64.
  • Clicking the "Customize in settings" button from the Onboarding modal redirects to the existing tab with the "about:preferences#privacy" page, Privacy pane.
  • When the Preferences page is displayed, the "Address Bar - Firefox Suggest" section is focused and highlighted in the page view.

Comment on attachment 9241851 [details] [diff] [review]
93/beta & 92/release patch

Approved for 92.0.1.

Attachment #9241851 - Flags: approval-mozilla-release? → approval-mozilla-release+
  • I have verified this issue using the Candidate 92.0.1 build (Build ID: 20210920202613) on Windows 10 x64, macOS 10.15.7 and Linux Ubuntu 20.04 x64.

  • Clicking the "Customize in settings" button from the Onboarding modal redirects to the existing tab with the "about:preferences#privacy" page, Privacy pane.

  • When the Preferences page is displayed, the "Address Bar - Firefox Suggest" section is focused and highlighted in the page view.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.