Closed Bug 1731152 Opened 4 months ago Closed 4 months ago

Spotlight link has unexpected border in HCM mode

Categories

(Firefox :: Messaging System, defect, P1)

Desktop
Windows
defect

Tracking

()

VERIFIED FIXED
94 Branch
Iteration:
94.2 - Sep 20 - Oct 3
Tracking Status
firefox93 --- wontfix
firefox94 --- verified

People

(Reporter: morgan, Assigned: dmosedale)

References

(Blocks 3 open bugs)

Details

(Whiteboard: [hcm-2021-h2])

Attachments

(1 file, 3 obsolete files)

STR:

  1. Enable High Contrast Mode in Windows settings
  2. set this pref to true: browser.newtabpage.activity-stream.asrouter.devtoolsEnabled
  3. navigate to about:newtab#asrouter
  4. search in page for "Spotlight" and click the "Show" button associated.
  5. view the popup, mouseover each button

Expected:
The "Stay protected..." button inverts on mouseover
The "Not now" button uses the user's foreground and background colors
On mouseover, the button inverts (or indicates mouseover in some other way, but remains visibly a button).

Actual:
The "Stay protected..." button changes to use the user's foreground and background colors, losing its "preferred" indication.
The button uses the user's background and hyperlink colors
On mouseover, the button loses its border, bleeds into the page, and gains underline text styling as if it were a link

Blocks: 1721730

This is not blocker for experiment. This should be blocking accessibility bug for this feature. NI Dan to help with that thanks!

Flags: needinfo?(dmosedale)
No longer blocks: 1721730
Flags: needinfo?(dmosedale)
Attached image fixed version (obsolete) —
Assignee: nobody → dmosedale

Although they are both semantically buttons, the "Not Now" thing is supposed to look and feel like a link.

Morgan just looked at the fixed version screencast that I just attached and said it looks good. I'll upload the patch that generated the above screencast shortly.

For this patch, I'm working around theme bugs just for this dialog, because I'd like it to be upliftable to 93 beta if possible. Something that does the right fixes won't be upliftable -- they will effect substantially more than just this dialog and require some discussion.

[Tracking Requested - why for this release]:

We'd like to have something that looks better for high-contrast themes, since if the captive portal experiment goes well, we hope to start rolling out the feature during 93 release.

The QA verification for this bug is really just to make sure that it looks like the screencast attachment on Windows.

FYI, our last beta builds today, this needs to land asap and an uplift request. Thanks

After reconsidering Mardak's review comments and looking at timing, I think the better thing to do is get the right fix in after 93 rather than try and jam this workaround in at the last second. I'm going withdraw this from 93 uplift consideration and solicit feedback for the longer-term patch direction.

Severity: -- → S3
Iteration: --- → 94.2 - Sep 20 - Oct 3
Priority: -- → P1
Attachment #9242593 - Attachment is obsolete: true

.

Flags: needinfo?(mreschenberg)
Blocks: 1516766
Flags: needinfo?(mreschenberg)
Attachment #9243996 - Attachment is obsolete: true
Summary: Inconsistent button behaviour with HCM → Spotlight link has unexpected border in HCM mode
Attachment #9242572 - Attachment is obsolete: true
Pushed by dmosedale@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cfd8f0c6aadb
Fix spotlight dialog link in HCM mode, r=morgan
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch
Flags: qe-verify+

Confirmed issue with 94.0a1Build ID 20210916214506 on Win10.
Fix verified with 94.0b2.

Based on Comment 14, I'm marking this issue as Verified Fixed.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Whiteboard: [hcm-2021-h2]
Blocks: 1739252
You need to log in before you can comment on or make changes to this bug.