Closed Bug 1731156 Opened 1 year ago Closed 11 months ago

Crash in [@ mozilla::widget::WlCrashHandler]: error marshalling arguments for start_drag (signature ?oo?ou): null value passed for arg 1

Categories

(Core :: Widget: Gtk, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1730533

People

(Reporter: mccr8, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: crash)

Crash Data

Crash report: https://crash-stats.mozilla.org/report/index/96cbda16-5ac8-4fc4-8208-4137b0210916

MOZ_CRASH Reason: ```error marshalling arguments for start_drag (signature ?oo?ou): null value passed for arg 1


Top 10 frames of crashing thread:

0 libxul.so mozilla::widget::WlCrashHandler widget/gtk/nsWaylandDisplay.cpp:328
1 libwayland-client.so.0 wl_array_copy
2 libwayland-client.so.0 wl_log_set_handler_client
3 libwayland-client.so.0 wl_proxy_marshal_array_constructor_versioned
4 libwayland-client.so.0 wl_proxy_marshal
5 libgdk-3.so.0 gdk_wayland_window_set_application_id
6 libgtk-3.so.0 gtk_drag_set_icon_widget
7 libgtk-3.so.0 gtk_drag_begin
8 libxul.so nsDragService::InvokeDragSessionImpl widget/gtk/nsDragService.cpp:375
9 libxul.so nsBaseDragService::InvokeDragSession widget/nsBaseDragService.cpp:359

Blocks: wayland

For the record, crashing in WlCrashHandler() is intentional and before bug 1726923 AFAICS[1][2][3] this would have been a "silent" crash, only printing "Error [...] dispatching to Wayland display." on the console and not spawning the crash reporter.

So great that we now catch it. I guess a more descriptive bug title would be "error marshalling arguments for start_drag (signature ?oo?ou): null value passed for arg 1" though, as that's the specific bug. "Crash in [@ mozilla::widget::WlCrashHandler]" will, for now, always happen for protocol errors, no matter which one.

1: https://gitlab.freedesktop.org/wayland/wayland/-/blob/main/src/connection.c#L668-672
2: https://gitlab.freedesktop.org/wayland/wayland/-/blob/main/src/wayland-client.c#L842-845
3: https://gitlab.gnome.org/GNOME/gtk/-/blob/gtk-3-24/gdk/wayland/gdkeventsource.c#L201-205

Summary: Crash in [@ mozilla::widget::WlCrashHandler] → Crash in [@ mozilla::widget::WlCrashHandler]: error marshalling arguments for start_drag (signature ?oo?ou): null value passed for arg 1
Priority: -- → P3

Can you please try to reproduce with latest nightly?
Thanks.

Flags: needinfo?(continuation)

I was not experiencing this myself. I just filed a bug based on crash-stats.

Flags: needinfo?(continuation)

Okay, gtk_drag_set_icon_widget() should be fixed now.

Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1730533
You need to log in before you can comment on or make changes to this bug.