Closed Bug 1731174 Opened 11 months ago Closed 11 months ago

Thunderbird on Fedora consistently crashed @ nsXPCWrappedJS::AddRef when trying to open a pdf attachment

Categories

(Thunderbird :: General, defect)

Thunderbird 91
Unspecified
Linux
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1175168

People

(Reporter: essin, Unassigned, NeedInfo)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:92.0) Gecko/20100101 Firefox/92.0

Steps to reproduce:

Fedora 34 with all updates

Received an email with a pdf attachment
Rt-clicked and chose open

Actual results:

Thunderbird crashed.
Repeated 3 times.
Thunderbird crashed each time

Expected results:

It should not have crashed

There is no "Crash Reports" section in the Troubleshooting Information and there are no crash reports in ~/.thunderbird/Crash Reports (which I assume is a directory). There isn't even a Crash Reports directory.

It goes away so abruptly that I can't see how it would have time to log anything. One second it's there. The next second some kind of viewer flashed on the screen with an empty window, then - boom - everything just disappears.

Flags: needinfo?(essin)

Does this reproduce with a download from https://www.thunderbird.net/ ?

Flags: needinfo?(essin)

The crash reporter in the Fedora distributed version is disabled in the Configure options.

However, I can not reproduce a crash.

A right-click on a PDF attachment asks me what application I want to open the file with and works properly.

A left-click opens the file in the built-in PDF Viewer.

Got the download from https://www.thunderbird.net/
removed original install
ran new version
left-click on pdf does nothing
rt-click on pdf gives menu, chose Open, got:
Crash ID: bp-498c23c1-7289-4e52-9afc-d82790210917

and

AdapterDeviceID: 0x9bc5
AdapterDriverVendor: mesa/iris
AdapterDriverVersion: 21.1.8.0
AdapterVendorID: 0x8086
Add-ons: default-theme%40mozilla.org:1.2,google%40search.mozilla.org:1.0,ddg%40search.mozilla.org:1.0,amazondotcom%40search.mozilla.org:1.1,wikipedia%40search.mozilla.org:1.0,bing%40search.mozilla.org:1.0
AvailablePageFile: 24279146496
AvailablePhysicalMemory: 49699450880
AvailableSwapMemory: 8589930496
AvailableVirtualMemory: 58923958272
BuildID: 20210916142849
ContentSandboxCapabilities: 119
ContentSandboxCapable: 1
ContentSandboxLevel: 0
CrashTime: 1631899444
DOMIPCEnabled: 1
DesktopEnvironment: xfce
EventLoopNestingLevel: 1
FramePoisonBase: 9223372036600930304
FramePoisonSize: 4096
InstallTime: 1631899201
IsWayland: 0
MozCrashReason: MOZ_RELEASE_ASSERT(NS_IsMainThread()) (nsXPCWrappedJS::AddRef called off main thread)
Notes: FP(D00-L1000-W00000000-T000) WR? WR+ OMTP? OMTP- libGL.so.1? libGL.so.1+ GL Context? GL Context+
ProductID: {3550f703-e582-4d05-9a08-453d09bdfdc6}
ProductName: Thunderbird
ReleaseChannel: release
SafeMode: 0
StartupCrash: 0
StartupTime: 1631899201
TelemetryEnvironment: {"build":{"applicationId":"{3550f703-e582-4d05-9a08-453d09bdfdc6}","applicationName":"Thunderbird","architecture":"x86-64","buildId":"20210916142849","version":"91.1.1","vendor":null,"displayVersion":"91.1.1","platformVersion":"91.1.0","xpcomAbi":"x86_64-gcc3","updaterAvailable":true},"partner":{"distributionId":null,"distributionVersion":null,"partnerId":null,"distributor":null,"distributorChannel":null,"partnerNames":[]},"system":{"memoryMB":64103,"virtualMaxMB":null,"cpu":{"extensions":["hasMMX","hasSSE","hasSSE2","hasSSE3","hasSSSE3","hasSSE4_1","hasSSE4_2","hasAVX","hasAVX2","hasAES"]},"os":{"name":"Linux","version":"5.13.15-200.fc34.x86_64","locale":"en-US"},"hdd":{"profile":{"model":null,"revision":null,"type":null},"binary":{"model":null,"revision":null,"type":null},"system":{"model":null,"revision":null,"type":null}},"gfx":{"D2DEnabled":null,"DWriteEnabled":null,"ContentBackend":"Skia","Headless":false,"EmbeddedInFirefoxReality":null,"adapters":[{"description":"Mesa Intel(R) UHD Graphics 630 (CML GT2)","vendorID":"0x8086","deviceID":"0x9bc5","subsysID":null,"RAM":0,"driver":null,"driverVendor":"mesa/iris","driverVersion":"21.1.8.0","driverDate":null,"GPUActive":true}],"monitors":[{"screenWidth":1920,"screenHeight":1080}],"features":{"compositor":"none","hwCompositing":{"status":"available"},"gpuProcess":{"status":"unused"},"wrQualified":{"status":"available"},"webrender":{"status":"available"},"wrCompositor":{"status":"blocklisted:FEATURE_FAILURE_WEBRENDER_COMPOSITOR_DISABLED"},"wrSoftware":{"status":"available"},"openglCompositing":{"status":"available"},"omtp":{"status":"disabled:FEATURE_FAILURE_DISABLED"}}},"appleModelId":null},"settings":{"blocklistEnabled":true,"e10sEnabled":true,"e10sMultiProcesses":8,"fissionEnabled":false,"telemetryEnabled":false,"locale":"en-US","intl":{},"update":{"channel":"release","enabled":true},"userPrefs":{"widget.content.allow-gtk-dark-theme":false,"widget.content.gtk-high-contrast.enabled":true},"sandbox":{"effectiveContentProcessLevel":0,"contentWin32kLockdownState":3},"addonCompatibilityCheckEnabled":true,"isDefaultBrowser":null},"profile":{}}
ThreadIdNameMapping: 78308:"IPC I/O Parent",78309:"Netlink Monitor",78310:"Socket Thread",78311:"Permission",78313:"JS Watchdog",78319:"TaskController Thread #0",78322:"TaskController Thread #3",78323:"TaskController Thread #4",78320:"TaskController Thread #1",78324:"TaskController Thread #5",78321:"TaskController Thread #2",78325:"TaskController Thread #6",78326:"TaskController Thread #7",78328:"Timer",78329:"Cache2 I/O",78330:"Cookie",78332:"BackgroundThreadPool #2",78334:"Worker Launcher",78339:"GLXVsyncThread",78345:"Renderer",78347:"WRWorker#1",78348:"WRWorker#2",78350:"WRWorker#4",78352:"WRWorker#6",78349:"WRWorker#3",78346:"WRWorker#0",78351:"WRWorker#5",78353:"WRWorker#7",78354:"WRWorkerLP#0",78355:"WRWorkerLP#1",78356:"WRWorkerLP#2",78358:"WRWorkerLP#4",78360:"WRWorkerLP#6",78357:"WRWorkerLP#3",78359:"WRWorkerLP#5",78361:"WRWorkerLP#7",78362:"Compositor",78363:"ImageIO",78364:"IPDL Background",78372:"QuotaManager IO",78374:"HTML5 Parser",78375:"StyleThread#0",78377:"StyleThread#2",78376:"StyleThread#1",78378:"StyleThread#3",78379:"StyleThread#4",78380:"StyleThread#5",78384:"ImageBridgeChld",78388:"WRRenderBackend#1",78386:"WRSceneBuilder#1",78387:"WRSceneBuilderLP#1",78395:"mozStorage #1",78396:"TRR Background",78397:"DNS Resolver #1",78398:"BgIOThreadPool #1",78400:"Breakpad Server",78403:"ProcessHangMon",78404:"GMPThread",78406:"WRSceneBuilder#2",78407:"WRSceneBuilderLP#2",78408:"WRRenderBackend#2",78434:"SwComposite",78435:"WRSceneBuilder#4",78436:"WRSceneBuilderLP#4",78437:"WRRenderBackend#4",78438:"SwComposite",78439:"WRSceneBuilder#5",78440:"WRSceneBuilderLP#5",78441:"WRRenderBackend#5",78442:"SwComposite",78444:"WRSceneBuilderLP#6",78443:"WRSceneBuilder#6",78445:"WRRenderBackend#6",78446:"SwComposite",78448:"WRSceneBuilderLP#7",78447:"WRSceneBuilder#7",78449:"WRRenderBackend#7",78465:"DOM Worker",78470:"mozStorage #4",78471:"mozStorage #5",78475:"StreamTrans #14",78483:"URL Classifier",78505:"localStorage DB",78572:"IMAP",78581:"localStorage DB",78589:"SwComposite",78590:"WRSceneBuilder#10",78591:"WRSceneBuilderLP#10",78592:"WRRenderBackend#10",78642:"IMAP",78660:"SwComposite",78661:"WRSceneBuilder#12",78663:"WRRenderBackend#12",78662:"WRSceneBuilderLP#12",78665:"SwComposite",78666:"WRSceneBuilder#13",78667:"WRSceneBuilderLP#13",78668:"WRRenderBackend#13",78672:"SwComposite",78674:"WRSceneBuilderLP#14",78673:"WRSceneBuilder#14",78675:"WRRenderBackend#14",78676:"SwComposite",78677:"WRSceneBuilder#15",78678:"WRSceneBuilderLP#15",78679:"WRRenderBackend#15",78708:"SwComposite",78709:"WRSceneBuilder#16",78710:"WRSceneBuilderLP#16",78711:"WRRenderBackend#16",78712:"SwComposite",78713:"WRSceneBuilder#17",78715:"WRRenderBackend#17",78714:"WRSceneBuilderLP#17",78724:"StreamTrans #21",78725:"SwComposite",78726:"WRSceneBuilder#18",78727:"WRSceneBuilderLP#18",78728:"WRRenderBackend#18",78729:"StreamTrans #22",78730:"IndexedDB #3",78731:"DOM Worker",78732:"DOM Worker",
Throttleable: 1
TotalPageFile: 75807223808
TotalPhysicalMemory: 67217293312
URL: about:blank
UptimeTS: 242.99253475
Version: 91.1.1
useragent_locale: en-US

Flags: needinfo?(essin)

also got (in terminal:
IPDL protocol error: Handler returned error code!

###!!! [Parent][DispatchAsyncMessage] Error: PClientManager::Msg_ExpectFutureClientSource Processing error: message was deserialized, but the handler returned false (indicating failure)

IPDL protocol error: Handler returned error code!

###!!! [Parent][DispatchAsyncMessage] Error: PClientManager::Msg_ForgetFutureClientSource Processing error: message was deserialized, but the handler returned false (indicating failure)

IPDL protocol error: Handler returned error code!

###!!! [Parent][DispatchAsyncMessage] Error: PClientManager::Msg_ExpectFutureClientSource Processing error: message was deserialized, but the handler returned false (indicating failure)

IPDL protocol error: Handler returned error code!

###!!! [Parent][DispatchAsyncMessage] Error: PClientManager::Msg_ForgetFutureClientSource Processing error: message was deserialized, but the handler returned false (indicating failure)

ExceptionHandler::GenerateDump cloned child 78733
ExceptionHandler::WaitForContinueSignal waiting for continue signal...
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
Exiting due to channel error.
Exiting due to channel error.

[1] + 78295 exit 11 /opt/thunderbird/thunderbird

(In reply to Daniel Essin from comment #5)

...
Crash ID: bp-498c23c1-7289-4e52-9afc-d82790210917

Thanks. The signature is @ nsXPCWrappedJS::AddRef so perhaps we end up duping this to bug 1175168 where analysis is ongoing.

FWIW, a patch did ship in 91.0 - Bug 1663859 - Crash when opening an PDF attachment from IMAP

Severity: -- → S2
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
Flags: needinfo?(mkmelin+mozilla)
Keywords: crash
OS: Unspecified → Linux
Summary: Thunderbird on Fedora crashed when trying to open a pdf attachment → Thunderbird on Fedora consistently crashed when trying to open a pdf attachment

It's possible/likely they are related. I guess we can keep this open until we know.

Flags: needinfo?(mkmelin+mozilla)
Blocks: tb91found

(In reply to Daniel Essin from comment #5)

Got the download from https://www.thunderbird.net/
removed original install
ran new version
left-click on pdf does nothing
rt-click on pdf gives menu, chose Open, got:
Crash ID: bp-498c23c1-7289-4e52-9afc-d82790210917

@ nsXPCWrappedJS::AddRef suggests bug 1175168

We can reopen if bug 1175168 doesn't solve this.

Status: NEW → RESOLVED
Closed: 11 months ago
Depends on: 1175168
Resolution: --- → DUPLICATE
Summary: Thunderbird on Fedora consistently crashed when trying to open a pdf attachment → Thunderbird on Fedora consistently crashed @ nsXPCWrappedJS::AddRef when trying to open a pdf attachment
Duplicate of bug: 1175168

91.2.1 shipped on Oct 22.
Have you had any crashes when using 91.2.1?
If so, which crash IDs?

Flags: needinfo?(essin)
Depends on: 1742991
You need to log in before you can comment on or make changes to this bug.