Closed Bug 1731203 Opened 10 months ago Closed 3 months ago

hook up language detection and spell check according to result

Categories

(Thunderbird :: Message Compose Window, enhancement)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 69687

People

(Reporter: mkmelin, Unassigned)

Details

We can easily detect the language of what's written. We can then spell check according to that language, and not mark everything as wrong... The correct language header of the email and it's content should also be applied.

https://searchfox.org/comm-central/search?q=LanguageDetector.jsm&path=

var { LanguageDetector } =
ChromeUtils.import("resource:///modules/translation/LanguageDetector.jsm");

var text = "Ok, använd rätt språk!";
var r = LanguageDetector.detectLanguage(text).then((data) => {
  alert(JSON.stringify(data));
})

I am sometimes mixing several languages in the same email. This approach here would still mark those emails as all wrong.

Therefore, instead of detecting languages, bug 1402822 asks to allow several languages at once. As a user, I would download the dictionaries of the languages that I can speak and write, and the spellchecker would allow all of them.

That said, if this proposal here can be implemented quickly, I would be grateful. It's still a step ahead.

Blocks: 1733738

We've duped previous suggestions like this to Bug 69687, so I'm going to do that here as well.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 69687
See Also: 69687
No longer blocks: 1733738
You need to log in before you can comment on or make changes to this bug.