Sending mail gives 'Unable to connect to SMTP server %S'

RESOLVED DUPLICATE of bug 146488

Status

MailNews Core
Networking: SMTP
--
major
RESOLVED DUPLICATE of bug 146488
16 years ago
9 years ago

People

(Reporter: Jan de Visser, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Sending mail used to work just fine, then last week stopped working with above
mentioned error message. Checking the 'Outgoing Server (SMTP)' settings did not
help, nor did upgrading from moz 1.1 to 1.2a. Note that my SMTP server is
functional; I tried several (my ISPs, localhost [exim/cygwin], and a third one),
all of which work fine with Outlook 2000. In the 1.1 version the 'OK' button of
the SMTP server config screen appeared dead as well, but this seems better in
1.2a. Here's the snippet of my prefs.js dealing with SMTP:

user_pref("mail.smtp.defaultserver", "smtp2");
user_pref("mail.smtpserver.smtp2.auth_method", 0);
user_pref("mail.smtpserver.smtp2.hostname", "localhost");
user_pref("mail.smtpserver.smtp2.port", 25);
user_pref("mail.smtpserver.smtp2.try_ssl", 1);
user_pref("mail.smtpserver.smtp2.username", "");
user_pref("mail.smtpservers", "smtp2");

Updated

16 years ago
QA Contact: sheelar → esther
(Reporter)

Comment 1

16 years ago
Hrrmmm... Further research unveiled that the links between my mail accounts and
my smtp servers in prefs.js was fubared. My 'primary' account pointed to smtp
server smtp3, which wasn't present. Before today I never manually editted my
prefs.js however, so something must have gotten confused at some point...

*** This bug has been marked as a duplicate of 146488 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.