Closed Bug 1731604 Opened 1 month ago Closed 11 days ago

200.07 - 4.52% perf_reftest bloom-basic-2.html / tp5o + 1 more (Windows) regression on Thu September 16 2021

Categories

(Core :: DOM: Content Processes, defect, P2)

defect

Tracking

()

RESOLVED FIXED
Fission Milestone MVP
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox92 --- unaffected
firefox93 --- unaffected
firefox94 + verified
firefox95 --- verified

People

(Reporter: aesanu, Assigned: nika)

References

(Regression)

Details

(4 keywords, Whiteboard: fission-hard-blocker)

Perfherder has detected a talos performance regression from push 55fa1d670b119502b16f8795990f9456e1bfcd8c. As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

Ratio Test Platform Options Absolute values (old vs new)
200% perf_reftest bloom-basic-2.html windows10-64-shippable-qr e10s fission stylo webrender 1.28 -> 3.84
29% cross_origin_pageload windows10-64-shippable-qr e10s fission stylo webrender 250.28 -> 322.84
5% tp5o windows10-64-shippable-qr e10s fission stylo webrender 262.57 -> 274.43

Improvements:

Ratio Test Platform Options Absolute values (old vs new)
66% perf_reftest bloom-basic.html windows10-64-shippable-qr e10s fission stylo webrender 4.53 -> 1.53
11% perf_reftest_singletons inline-style-cache-1.html linux1804-64-shippable-qr e10s fission stylo webrender 1,152.46 -> 1,028.38
7% perf_reftest_singletons link-style-cache-1.html linux1804-64-shippable-qr e10s fission stylo webrender 475.15 -> 440.89
6% perf_reftest_singletons link-style-cache-1.html linux1804-64-shippable-qr e10s fission stylo webrender 477.54 -> 450.31

Details of the alert can be found in the alert summary, including links to graphs and comparisons for each of the affected tests. Please follow our guide to handling regression bugs and let us know your plans within 3 business days, or the offending patch(es) will be backed out in accordance with our regression policy.

For more information on performance sheriffing please see our FAQ.

Flags: needinfo?(nika)

same-origin loads are saved in the bfcache, which will affect when we process switch.

Nika says we should check if there is an existing process in the bfcache we should reuse when we swap BrowsingContextGroups.

Assignee: nobody → nika
Fission Milestone: ? → MVP
Priority: -- → P2
Whiteboard: fission-soft-blocker
Whiteboard: fission-soft-blocker → fission-hard-blocker

== Change summary for alert #31362 (as of Sat, 18 Sep 2021 15:02:58 GMT) ==

Regressions:

Ratio Test Platform Options Absolute values (old vs new)
24% amazon dcf windows10-64-shippable-qr fission warm webrender 361.21 -> 446.21
22% amazon ContentfulSpeedIndex windows10-64-shippable-qr fission warm webrender 398.25 -> 486.08
22% amazon SpeedIndex windows10-64-shippable-qr fission warm webrender 396.83 -> 482.33
20% amazon fcp windows10-64-shippable-qr fission warm webrender 330.92 -> 396.71
19% amazon fnbpaint windows10-64-shippable-qr fission warm webrender 337.58 -> 402.38
18% amazon PerceptualSpeedIndex windows10-64-shippable-qr fission warm webrender 404.50 -> 477.33
17% bing-search FirstVisualChange linux1804-64-shippable-qr fission warm webrender 240.00 -> 280.00
16% amazon FirstVisualChange windows10-64-shippable-qr fission warm webrender 374.79 -> 434.92
16% bing-search ContentfulSpeedIndex linux1804-64-shippable-qr fission warm webrender 261.67 -> 302.33
14% bing-search loadtime linux1804-64-shippable-qr fission warm webrender 217.42 -> 248.71
... ... ... ... ...
10% bing-search dcf linux1804-64-shippable-qr fission warm webrender 232.88 -> 255.08
7% bing-search PerceptualSpeedIndex linux1804-64-shippable-qr fission warm webrender 517.50 -> 555.58
7% instagram LastVisualChange windows10-64-shippable-qr fission warm webrender 844.54 -> 905.00
6% twitter ContentfulSpeedIndex macosx1015-64-shippable-qr fission warm webrender 842.67 -> 895.92
5% bing-search LastVisualChange linux1804-64-shippable-qr fission warm webrender 800.00 -> 840.00

For up to date results, see: https://treeherder.mozilla.org/perfherder/alerts?id=31362

See Also: → 1731792

I'm optimistic that these regressions will also be fixed by the changes in bug 1731792.

Flags: needinfo?(nika)
Depends on: 1731792
See Also: 1731792

(In reply to Nika Layzell [:nika] (ni? for response) from comment #3)

I'm optimistic that these regressions will also be fixed by the changes in bug 1731792.

@ Randell, do you think the improvements below from Nika's patch are good enough that we can resolve this bug as fixed?

Nika's patch improved perf_reftest bloom-basic-2.html, but the results are still noisy and not entirely back to the previous baseline:

https://treeherder.mozilla.org/perfherder/graphs?highlightAlerts=1&highlightChangelogData=1&series=autoland,3869358,1,1&timerange=7776000

Similar improvements on cross_origin_pageload, but not entirely back to the previous baseline:

https://treeherder.mozilla.org/perfherder/graphs?highlightAlerts=1&highlightChangelogData=1&series=autoland,3869400,1,1&timerange=2592000

tp5o, OTOH, looks fixed:

https://treeherder.mozilla.org/perfherder/graphs?timerange=2592000&series=autoland,3869735,1,1

Flags: needinfo?(rjesup)

Resolving as fixed because Randell says the new test results with Nika's fix for bug 1731792 are good enough.

Flags: needinfo?(rjesup)
Status: NEW → RESOLVED
Closed: 11 days ago
Resolution: --- → FIXED

Nika's fix for bug 1731792 landed in Nightly 94.

You need to log in before you can comment on or make changes to this bug.