Outer div has zero height when inner div is floated

RESOLVED INVALID

Status

()

Core
DOM: CSS Object Model
RESOLVED INVALID
16 years ago
13 years ago

People

(Reporter: Marc Chipouras, Assigned: jst)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

When one div is nested inside another div, if any of the inner divs are floated
in any direction the outer div then has zero height.  

Reproducible: Always

Steps to Reproduce:
1.create outer div with a border
2.nest a div inside of it
3.float the inner div and view

Actual Results:  
The outer div creates a border around a content of zero height and the inner div
shows as normal

Expected Results:  
The outer div should create a border around the inner div and the inner div
should appear to be wrapped by the outer div
(Reporter)

Comment 1

16 years ago
Created attachment 102071 [details]
Example case

Comment 2

16 years ago
CSS 2.1, section 10.6.3: http://www.w3.org/TR/CSS21/visudet.html#q17
"Only children in the normal flow are taken into account (i.e., floating boxes
and absolutely positioned boxes are ignored, and relatively positioned boxes are
considered without their offset). "

-->INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
*** Bug 229562 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.