*.RAR Files don' t download but are displayed as text files in browser window

VERIFIED INVALID

Status

Core Graveyard
File Handling
VERIFIED INVALID
16 years ago
2 years ago

People

(Reporter: Udo Matthaei, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

The above url is a link collection to a RAR-compressed file. 
- First entry does not load at all (seems to be a server error) 
- Second link loads the file contents into the browser window instead of opening 
the download dialog.
- The Third Link:
http://belnet.dl.sourceforge.net/sourceforge/ndub/nandub-binary-1.0rc2.rar
opens correctly the DL-Dialog (and downloads)
- The forth link:
http://cesnet.dl.sourceforge.net/sourceforge/ndub/nandub-binary-1.0rc2.rar
loads the file as text into the browser window again 
and so forth ...



Reproducible: Always

Steps to Reproduce:
1. goto >>> http://www.filemirrors.com/search.src?file=nandub-binary-1.0rc2.rar
2. click on second or forth link
3. look at the browser window

Actual Results:  
RAR-File is displayed as text in the browser window.

Expected Results:  
Open Download Dialog

I reproduced the Problem on three different systems 
1x W2k, 1x Win XP Professional, both behind a netgear RP114 Cable/DSL Router
1x W2k  behind Checkpoint Firewalls, eSafe Content Scanner, MS Proxy

No workaround could be figured out. We tried lots of different entries in 
"Preferences -> Navigator -> Helper Applications" without any succes what so ever.
You can right click and select save Link target as.
The server sends the wrong mime-type for the file (yes it works in IE because IE
is broken)

--00:54:15--  http://cesnet.dl.sourceforge.net/sourceforge/ndub/nandub-binary-1.
0rc2.rar
           => `nandub-binary-1.0rc2.rar'
Resolving cesnet.dl.sourceforge.net... done.
Connecting to cesnet.dl.sourceforge.net[195.113.161.88]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 821,448 [text/plain]

The server sends text/plain and Mozilla can of course render text/plain.


-> invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
v
Status: RESOLVED → VERIFIED

Comment 3

15 years ago
Is there a workaround. It seems like every server on the planet is broken, and
it's annoying as ****.

Every Apache server _is_ broken.  I've submitted a patch to them to fix it...

You can save using the context menu or shift-click.

And please cc yourself if you expect to get an answer, ok?

Comment 5

15 years ago
Thanks a bunch!   I've been on CC for half a year now (and on the vote-list), so
that's why I got a bit frustrated. 

Comment 6

14 years ago
*** Bug 216626 has been marked as a duplicate of this bug. ***
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.