crash with jre 1.4.1 plugin

RESOLVED DUPLICATE of bug 116444

Status

Core Graveyard
Java: OJI
RESOLVED DUPLICATE of bug 116444
16 years ago
7 years ago

People

(Reporter: Fernando Racca, Assigned: Joshua Xia)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; es-AR; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; es-AR; rv:1.1) Gecko/20020826

Using Slackware 9b (gcc 3.2) ext3 partitioning
./mozilla
INTERNAL ERROR on Browser End: Exec of "java_vm" failed: 2
<
System error?:: No such file or directory
Gdk-ERROR **: Fatal IO error 9 (Bad file descriptor) on X server :0.0.
INTERNAL ERROR on Browser End: Could not read ack from browser
System error?:: Resource temporarily unavailable

the plugin seems to be detected in about:plugins, but when i try to load a java
applet it crashes instantly

Reproducible: Always

Steps to Reproduce:
1.copy or link the libjavaplugin_oji.so (i have the j2sdk1.4.1 
# ln -s /usr/local/j2sk1.4.1/jre/plugins/i386/ns510/libjavaplugin_oji.so
/usr/local/mozilla/plugins/libjavaplugin_oji.so (or move it , as you wish :^) )
2. launch mozilla (as a single user o root) 
3. load a java enhanced web page

Actual Results:  
mozilla crashes

Expected Results:  
load the applet :)
You MUST symlink the plugin.
"Exec of "java_vm" failed: 2" indicates that you copied the plugin and mozilla
is crashing.

Comment 2

16 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: joe.chou → petersen
Status: UNCONFIRMED → NEW
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen

Comment 4

16 years ago
Fernando, have you checked that your java plugin is installed correctly? Are you
still having this problem? We get a lot of reports on this error and it's
usually an incorrectly installed plugin. See bug 95750 for example.
(Assignee)

Comment 5

15 years ago
Hi, Fernando

Can you reproduce the bug after install java correctly?
If not, I will close this bug.

Thanks!
Assignee: joe.chou → joshua.xia
Status: NEW → UNCONFIRMED

Comment 6

15 years ago
Yes, it is an known problem. Mozilla gcc 3.2 compiled version can't work 
correctly Java Plugin. Joshua, I think we already have a bug for this. Just 
mark as duplicate of that bug.
sorry i missed the GCC3.2 part.. (but I'm a win32 user :-)


*** This bug has been marked as a duplicate of 116444 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.