Closed Bug 1731793 Opened 1 year ago Closed 1 year ago

error message when closing browser toolbox (after using node picker?)

Categories

(DevTools :: Inspector, defect)

defect

Tracking

(firefox-esr78 unaffected, firefox-esr91 unaffected, firefox92 unaffected, firefox93 unaffected, firefox94 fixed)

RESOLVED FIXED
94 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox92 --- unaffected
firefox93 --- unaffected
firefox94 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

here's the message I see in the terminal:

TypeError: (destructured parameter) is undefined: _onInspectorFrontDestroyed@resource://devtools/client/inspector/node-picker.js:104:35
_emit@resource://devtools/shared/event-emitter.js:244:34
emit@resource://devtools/shared/event-emitter.js:190:18
emit@resource://devtools/shared/event-emitter.js:342:18
unmanage@resource://devtools/shared/protocol/Front.js:170:37
destroy@resource://devtools/shared/protocol/Pool.js:184:14
baseFrontClassDestroy@resource://devtools/shared/protocol/Front.js:110:13
destroy@resource://devtools/shared/protocol/Front.js:74:10
destroy@resource://devtools/client/fronts/inspector.js:113:11
_destroyTarget@resource://devtools/client/fronts/targets/target-mixin.js:641:17

This is triggered by https://searchfox.org/mozilla-central/rev/50c3cf7a3c931409b54efa009795b69c19383541/devtools/client/inspector/node-picker.js#104 , because we're missing the second parameter and we try to destructure it.
It probably comes from this callback https://searchfox.org/mozilla-central/rev/50c3cf7a3c931409b54efa009795b69c19383541/devtools/client/inspector/node-picker.js#137

onInspectorFrontDestroyed was throwing because when it
is called from the destroy callback of watchFronts, it
doesn't get a second argument, and the destructuring fails.
This patch defaults the second parameter to an empty object
in order to avoid this.

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0cab7f09323c
[devtools] Fix node picker error when closing browser toolbox. r=ochameau.
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch

Set release status flags based on info from the regressing bug 1729925

Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.