Closed Bug 1732034 Opened 1 month ago Closed 1 month ago

Perma OSError: [Errno 8] Exec format error: '/builds/worker/fetches/upx-3.95-win64/upx.exe'

Categories

(Firefox :: Installer, defect, P1)

defect

Tracking

()

RESOLVED FIXED
94 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox92 --- unaffected
firefox93 --- unaffected
firefox94 --- fixed

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Filed by: apavel [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=352361076&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/FocvjJ9oT9CHDeYE5F5PPw/runs/1/artifacts/public/logs/live_backing.log


[task 2021-09-22T11:40:44.060Z] 11:40:44     INFO -  Packaging .
[task 2021-09-22T11:40:44.060Z] 11:40:44     INFO -  /builds/worker/workspace/obj-build/_virtualenvs/build/bin/python /builds/worker/checkouts/gecko/config/nsinstall.py -D '/builds/worker/workspace/obj-build/dist/install/sea/'
[task 2021-09-22T11:40:44.100Z] 11:40:44     INFO -  /builds/worker/workspace/obj-build/_virtualenvs/build/bin/python /builds/worker/checkouts/gecko/mach repackage installer \
[task 2021-09-22T11:40:44.100Z] 11:40:44     INFO -    -o '/builds/worker/workspace/obj-build/dist/install/sea/firefox-94.0a1.ach.win64.installer.exe' \
[task 2021-09-22T11:40:44.100Z] 11:40:44     INFO -    --package-name 'firefox' \
[task 2021-09-22T11:40:44.100Z] 11:40:44     INFO -    --package '/builds/worker/workspace/obj-build/dist/firefox-94.0a1.ach.win64.zip' \
[task 2021-09-22T11:40:44.100Z] 11:40:44     INFO -    --tag /builds/worker/checkouts/gecko/browser/installer/windows/app.tag \
[task 2021-09-22T11:40:44.100Z] 11:40:44     INFO -    --setupexe l10ngen/setup.exe \
[task 2021-09-22T11:40:44.100Z] 11:40:44     INFO -    --sfx-stub /builds/worker/checkouts/gecko/other-licenses/7zstub/firefox/7zSD.Win32.sfx \
[task 2021-09-22T11:40:44.100Z] 11:40:44     INFO -    --use-upx
[task 2021-09-22T11:40:45.956Z] 11:40:45     INFO -  Error running mach:
[task 2021-09-22T11:40:45.957Z] 11:40:45     INFO -      ['repackage', 'installer', '-o', '/builds/worker/workspace/obj-build/dist/install/sea/firefox-94.0a1.ach.win64.installer.exe', '--package-name', 'firefox', '--package', '/builds/worker/workspace/obj-build/dist/firefox-94.0a1.ach.win64.zip', '--tag', '/builds/worker/checkouts/gecko/browser/installer/windows/app.tag', '--setupexe', 'l10ngen/setup.exe', '--sfx-stub', '/builds/worker/checkouts/gecko/other-licenses/7zstub/firefox/7zSD.Win32.sfx', '--use-upx']
[task 2021-09-22T11:40:45.957Z] 11:40:45     INFO -  The error occurred in code that was called by the mach command. This is either
[task 2021-09-22T11:40:45.957Z] 11:40:45     INFO -  a bug in the called code itself or in the way that mach is calling it.
[task 2021-09-22T11:40:45.957Z] 11:40:45     INFO -  You can invoke |./mach busted| to check if this issue is already on file. If it
[task 2021-09-22T11:40:45.957Z] 11:40:45     INFO -  isn't, please use |./mach busted file repackage| to report it. If |./mach busted| is
[task 2021-09-22T11:40:45.957Z] 11:40:45     INFO -  misbehaving, you can also inspect the dependencies of bug 1543241.
[task 2021-09-22T11:40:45.957Z] 11:40:45     INFO -  If filing a bug, please include the full output of mach, including this error
[task 2021-09-22T11:40:45.957Z] 11:40:45     INFO -  message.
[task 2021-09-22T11:40:45.957Z] 11:40:45     INFO -  The details of the failure are as follows:
[task 2021-09-22T11:40:45.957Z] 11:40:45     INFO -  OSError: [Errno 8] Exec format error: '/builds/worker/fetches/upx-3.95-win64/upx.exe'
[task 2021-09-22T11:40:45.958Z] 11:40:45     INFO -    File "/builds/worker/checkouts/gecko/python/mozbuild/mozbuild/mach_commands.py", line 2025, in repackage_installer
[task 2021-09-22T11:40:45.958Z] 11:40:45     INFO -      repackage_installer(
[task 2021-09-22T11:40:45.958Z] 11:40:45     INFO -    File "/builds/worker/checkouts/gecko/python/mozbuild/mozbuild/repackaging/installer.py", line 51, in repackage_installer
[task 2021-09-22T11:40:45.958Z] 11:40:45     INFO -      archive_exe(package_name, tag, sfx_package, output, use_upx)
[task 2021-09-22T11:40:45.958Z] 11:40:45     INFO -    File "/builds/worker/checkouts/gecko/python/mozbuild/mozbuild/action/exe_7z_archive.py", line 31, in archive_exe
[task 2021-09-22T11:40:45.958Z] 11:40:45     INFO -      subprocess.check_call(
[task 2021-09-22T11:40:45.958Z] 11:40:45     INFO -    File "/usr/lib/python3.9/subprocess.py", line 368, in check_call
[task 2021-09-22T11:40:45.958Z] 11:40:45     INFO -      retcode = call(*popenargs, **kwargs)
[task 2021-09-22T11:40:45.958Z] 11:40:45     INFO -    File "/usr/lib/python3.9/subprocess.py", line 349, in call
[task 2021-09-22T11:40:45.958Z] 11:40:45     INFO -      with Popen(*popenargs, **kwargs) as p:
[task 2021-09-22T11:40:45.958Z] 11:40:45     INFO -    File "/usr/lib/python3.9/subprocess.py", line 951, in __init__
[task 2021-09-22T11:40:45.958Z] 11:40:45     INFO -      self._execute_child(args, executable, preexec_fn, close_fds,
[task 2021-09-22T11:40:45.958Z] 11:40:45     INFO -    File "/usr/lib/python3.9/subprocess.py", line 1823, in _execute_child
[task 2021-09-22T11:40:45.958Z] 11:40:45     INFO -      raise child_exception_type(errno_num, err_msg, err_filename)
[task 2021-09-22T11:40:46.000Z] 11:40:46    ERROR -  make[2]: *** [/builds/worker/checkouts/gecko/toolkit/mozapps/installer/windows/nsis/makensis.mk:67: installer] Error 1
[task 2021-09-22T11:40:46.000Z] 11:40:46     INFO -  make[2]: Leaving directory '/builds/worker/workspace/obj-build/browser/installer/windows'
[task 2021-09-22T11:40:46.000Z] 11:40:46    ERROR -  make[1]: *** [Makefile:96: package-win32-installer] Error 2
[task 2021-09-22T11:40:46.000Z] 11:40:46     INFO -  make[1]: Leaving directory '/builds/worker/workspace/obj-build/browser/locales'
[task 2021-09-22T11:40:46.000Z] 11:40:46     INFO -  make: *** [Makefile:110: installers-ach] Error 2
[task 2021-09-22T11:40:46.000Z] 11:40:46    ERROR - Return code: 2
[task 2021-09-22T11:40:46.000Z] 11:40:46    ERROR - make installers-ach failed
[task 2021-09-22T11:40:46.001Z] 11:40:46    ERROR - failure: repack_locale(ach)
[task 2021-09-22T11:40:46.001Z] 11:40:46    ERROR - # TBPL FAILURE #
[task 2021-09-22T11:40:46.001Z] 11:40:46  WARNING - setting return code to 2

Hi Nick, can you please take a look?

Flags: needinfo?(nalexander)

This breaks l10n repacks on nightly.

Severity: S4 → S1
Keywords: regression
Priority: P5 → P1

Likely caused by bug 1731223.

Regressed by: 1731223
Flags: needinfo?(nalexander) → needinfo?(mh+mozilla)

(In reply to Julien Cristau [:jcristau] from comment #3)

Likely caused by bug 1731223.

Yes, hit the nail here. glandium made several changes to the way these were invoked, probably just needs a bump on the l10n repack jobs.

Status: NEW → RESOLVED
Closed: 1 month ago
Flags: needinfo?(mh+mozilla)
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch
You need to log in before you can comment on or make changes to this bug.