Keychain dialog keyboard navigation needs fixing

RESOLVED FIXED in Camino0.9

Status

Camino Graveyard
Accessibility
P4
minor
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: Mike Ely, Assigned: Simon Fraser)

Tracking

unspecified
Camino0.9
PowerPC
Mac OS X

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021007 Chimera/0.5+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021007 Chimera/0.5+

This may or may not be an OS X bug/feature.  Buttons in drop-down panes are not
tab-selectable, even if one button is default selected.  This results in a
forced dual-mode interface, where the user has a keyboard option for only one
choice but must use the mouse to gain access to the other option.  Considering
Mac users' renowned preference for five-button cmd-apple-esc-shift-return type
of UI, this presents a more serious problem than one might expect.

Reproducible: Always

Steps to Reproduce:
1.  Ensure that preference is enabled allowing Navigator to store passwords.
2.  Go to some any site which requires a login and create a user account, such
as the one listed above.
3.  Attempt to tab from "Remember Password" to "Don't Remember" without using
the mouse.

Actual Results:  
The "Remember Password" button remained selected, and the "Don't Remember"
button remained unselected.

Expected Results:  
The "Don't Remember" button should have been selected so that it could be
activated by pressing the Return key on the keyboard, and the "Remember
Password" button should have been unselected.

Comment 1

16 years ago
Confirmed using Chimera/2002100304 on 10.1.5. Reassigning to Accessibility.

(Note: some other sheets have tab focus problems, too. For example, the basic
auth sheet allows tabbing from the text fields to the buttons and checkboxes,
but the tab cycle doesn't repeat back to the text fields, instead cycling
through only the buttons and checkbox. Shift-tab does return focus to the text
fields, though.)
Assignee: brade → bryner
Status: UNCONFIRMED → NEW
Component: Toolbars & Menus → Accessibility
Ever confirmed: true
(Assignee)

Comment 2

16 years ago
We need some nib loving here.
Assignee: bryner → sfraser
(Assignee)

Updated

16 years ago
Summary: Buttons not tab-selectable → Keychain dialog keyboard navigation needs fixing
This bug is still valid. While the user can hit Esc to not remember, there is no
way to select the third option to never remember. Marking for 1.0. This is
something we need to have fixed for accessibility.
Priority: -- → P4
Target Milestone: --- → Camino1.0
Isn't this handled by the OS's full keyboard access?
One would think. But apparently it's broken in Camino. I turned on the access
and couldn't get it to work.

Comment 6

13 years ago
Created attachment 179853 [details]
nib with some loving

Just made sure the NextKeyView stuff was hooked up correctly in IB.

Updated

13 years ago
Attachment #179853 - Flags: review?(sfraser_bugs)
*** Bug 300078 has been marked as a duplicate of this bug. ***
Mike set the dupe for 0.9 when it was submitted, citing low-hanging fruit, and
as  there's already a nib with fixes sitting here, I'm moving the 0.9 target
over from the dupe so we don't lose track of this.

Jasper, is this nib still OK, or have there been other nib changes since you
generated it?
Target Milestone: Camino1.0 → Camino0.9
(Assignee)

Comment 9

13 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Comment on attachment 179853 [details]
nib with some loving

Removing obsolete request on fixed bug; apologies for bugspam.
Attachment #179853 - Flags: review?(sfraser_bugs)
You need to log in before you can comment on or make changes to this bug.