Cannot download to mapped network drives / samba shares

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: eric, Assigned: bugzilla)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla v1.2a
When trying to download a file, If I attempt to save to "MyComputer" or a
network Drive all network drives are disconnected.
The network drives mapped, are shared from a samba server, smbd version 2.2.3a 
I havent been able to try this with windows shares mapped, I would think that it
might have a diffrent outcome.

Updated

16 years ago
Depends on: 101953
QA Contact: sairuh → petersen

Comment 1

16 years ago
*** Bug 182228 has been marked as a duplicate of this bug. ***

Comment 2

16 years ago
Confirming, with Samba 2.0.7 (ok its quite old, but the behavior would be the
same I think): I can't download to mapped drives, for example \\Server\homes is
mapped to the Letter I:, but I can't save there directly. The download manager
then doesn't show any download. With saving on local disk all works fine.

Updated

16 years ago
Blocks: 101953
No longer depends on: 101953

Comment 3

16 years ago
I have the same problem. But It's a little different on Mozilla 1.3.

When I want to download a file to a Network drive for some reason mozilla
doenloads the file to a different directory. Once the download is complete,
mozilla will copy the file from a temp directory to the place you told it to
download too.

I thought my mozilla locked up or crashed. But, on my machine, once a file is
done downloading mozilla will not respond till the file is finished being copied
over to the network drive. On big ISO downloads (files that are 100's of MB) it
can take upto 5 mins for the copy to happen over the network. If mozilla is
killed the downloaded file is destroyed/lost like it was never downloaded.

I lost many files this way thinking "WTF! Mozilla locked up when the download
finally for 97%!!!! AH!" then killed the mozilla process....

I think the code needs to be changed to directly save the file to the target
directory.

-Bryan

Comment 4

15 years ago
worksforme (diff version of Samba)

Mozilla 1.5RC1 on Win2k downloading to mapped share on RedHat 9 machine using
Samba 3.0.0.

Comment 5

15 years ago
Correction to comment #4:

I do see behavior like comment #3 with Mozilla freezing while files are being
copied to the shares. However, I do not have disconnections or issues as
described in comment #2 or original bug description.

Comment 6

15 years ago
to comment 3:

That delay/freeze is bug 103766. The cause is bug 69938.

Comment 7

15 years ago
Works for Me, Moz 1.8a (nightly 2004071417). Has for a long time. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.