Table elements aren't aligned properly. Because of <pre>?

RESOLVED FIXED

Status

()

Core
Layout
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: 石庭豐 (Seak, Teng-Fong), Assigned: Marc Attinasi)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: WONTFIX?, URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20020930
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20020930

Look at the page.  The third column is shifted to the top (or the 1st and 2nd
column shifted to the bottom?)  I've seen the code but I can't find anything
wrong, except that there is a </p> at the end of each <tr> element.

I suspect it's because of <pre> which forces a newline before it.  I'm wondering
if it's really necessary to do so.  Can't <pre> (and all kind of block elements)
be more intelligent not to do so when it's already at the beginning of a new line?

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
Confirming bug with 2002100317, the problem seems to be related to the <pre> tags, 
or the <a name=..."> tags. As you can see in the simplified testcase, if you
remove either one of them, the alignment problems disappear.
 

Comment 2

15 years ago
Created attachment 102162 [details]
simplified testcase

Comment 3

15 years ago
Created attachment 102167 [details]
testcase with visible borders
The <pre> has a margin by default.  In quirks mode, we remove the margin of the
first child of a table.  But in this case, the first child is <a>, not <pre>, so
the margin does not get removed.

Our existing quirk works for enough pages that I don't see a really good reason
to change it...
OS: Windows 2000 → All
Hardware: PC → All
Keywords: testcase
Whiteboard: WONTFIX?
The site's been redesigned, and the current JSref looks OK now. Since this seems
to have really been a site problem, marking FIXED.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.