Factor out common code for opening a message in an existing message window

RESOLVED FIXED

Status

SeaMonkey
MailNews: Message Display
--
minor
RESOLVED FIXED
16 years ago
8 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

16 years ago
Drag-drop and double-click to open a message in an existing message window
should be using the same code.
(Assignee)

Comment 1

16 years ago
Fixing this also means that windows wanting to open a message URI in an existing
window won't need their own messenger instance.
QA Contact: olgam → stephend
(Assignee)

Comment 2

15 years ago
Created attachment 109157 [details] [diff] [review]
Proposed patch
(Assignee)

Updated

15 years ago
Attachment #109157 - Flags: superreview?(sspitzer)
Attachment #109157 - Flags: review?(ssu)

Comment 3

15 years ago
Comment on attachment 109157 [details] [diff] [review]
Proposed patch

it's failing to update the mail toolbar now.

1) double click a message from inbox.
2) go to a newsgroup and double click on a message there.

notice that the following toolbar buttons have not changed as follows:
  Delete -> Junk
  Junk -> Mark

It gets changed if you go to another folder and double click on a message there
(must be in a different folder).

Looks like it's one step behind where user is clicking.
Attachment #109157 - Flags: review?(ssu) → review-
(Assignee)

Comment 4

15 years ago
I see the problem with cross folder navigation, too...
(Assignee)

Comment 5

15 years ago
Comment on attachment 109157 [details] [diff] [review]
Proposed patch

Sean, you can try again now :-)
Attachment #109157 - Flags: review- → review?(ssu)

Comment 6

15 years ago
Comment on attachment 109157 [details] [diff] [review]
Proposed patch

patch has bit-rotted.  I tried merging to trunk, but it regresses bug 187673.
Attachment #109157 - Flags: review?(ssu) → review-
(Assignee)

Comment 7

15 years ago
Yes, the problem is that I need to clone the DB view from the drag-n-drop (which
is currently broken for this reason).
Product: Browser → Seamonkey

Comment 8

11 years ago
Neil, should review be canceled?  Is refactor still possible?
Severity: normal → minor
OS: Windows 95 → All
Hardware: PC → All
(Assignee)

Comment 9

10 years ago
Created attachment 282890 [details] [diff] [review]
Simpler patch

I gave up trying to factor out any more common code (unless there's any obvious factoring that you can see) and just made it so drag-n-drop works the same as reusing an existing message window from the menu (e.g. next now works properly)
Assignee: ssu0262 → neil
Status: NEW → ASSIGNED
Attachment #282890 - Flags: review?(mnyromyr)

Comment 10

10 years ago
(In reply to comment #9)
> Created an attachment (id=282890) [details]
> Simpler patch
> 
> I gave up trying to factor out any more common code (unless there's any obvious
> factoring that you can see)

Perhaps your question is for Karsten.  If it's for me, sorry I don't know.

just to get it in the bug comments, part of the patch cites Bug 187673 – Mail title is not consistent with the mail message

Comment 11

10 years ago
Comment on attachment 282890 [details] [diff] [review]
Simpler patch

Neil, I don't see what this should fix, could you please elaborate?
(Assignee)

Comment 12

10 years ago
Sure... this fixes the bug that after you drag a message into a message window the navigation doesn't update in the same way that opening a message in a window does when it reuses a window, that is to say, opening a message in a window sets that window's folder and current message, while dragging currently loads the message but the window still thinks the previous message and folder are current.

Comment 13

10 years ago
Comment on attachment 282890 [details] [diff] [review]
Simpler patch

Some steps for those who want to understand what's going on here - I only found out accidently (and having no useful steps to reproduce really sucks, Neil):
1. Go into threaded view, all threads collapsed.
2. Doubleclick a message,  it'll open in a message window.
3. Hitting F will walk to the next thread, as it would in the main window.
4. In the main window, switch to sort by date.
5. Drag a message into the message window.
6. Hitting F repatedly will still think it's in threaded view.

With this patch, 6. will follow the view set when the dragging started, which is sort by date in my example above.
Attachment #282890 - Flags: review?(mnyromyr) → review+
(Assignee)

Comment 14

10 years ago
Created attachment 289726 [details] [diff] [review]
TB port of drag'n'drop fix
Attachment #289726 - Flags: superreview?(bienvenu)

Updated

10 years ago
Attachment #289726 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Comment 15

10 years ago
Drag'n'drop fixes checked in, therefore marking bug fixed, as far as it goes.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Comment on attachment 109157 [details] [diff] [review]
Proposed patch

This bug was fixed by a later patch. Removing obsolete request and obsoleting patch.
Attachment #109157 - Attachment is obsolete: true
Attachment #109157 - Flags: superreview?(sspitzer)
You need to log in before you can comment on or make changes to this bug.