"The current command did not succeed. The mail server responded: One or more arguments are invalid."

RESOLVED INVALID

Status

MailNews Core
Networking: IMAP
--
major
RESOLVED INVALID
16 years ago
10 years ago

People

(Reporter: Manik Surtani, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
Using Mozilla 1.1.

This popup alert happens whenever I check for new messages via IMAP, talking to
a M$ Exchange 5.5 server.  (both manually and checking mail automatically)

It retrieves the mails fine, filters them into folders according to the rules I
have set up, etc etc.  But this annoying alert still comes up.  

As a result, I have to check mail manually and cancel the alert as it comes up -
otherwise, if I leave it to check mail periodically and I leave my desk for a
while, I come back to a screen full of alerts which need to be closed individually.

It does NOT happen when I talk to my second IMAP account, which is on a Linux
server.
(Reporter)

Comment 1

16 years ago
Created attachment 102135 [details]
Screen shot of the popup error

This is a screen shot of the error popup.
(Reporter)

Updated

16 years ago
Keywords: mail4, mail6, mozilla1.1

Comment 2

16 years ago
Please attach a IMAP log of the problem.
Check: http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
(Reporter)

Comment 3

16 years ago
Created attachment 102151 [details]
imap logs for this error.

Ignore the log messages for pop.inbox.lv - this server (to which I also connect
via IMAP) works fine.

The other IMAP server (192.168.2.2 in the logs) is the M$ Exchange server on
which I see this problem.

Apologies for not having uploaded this earlier...

Comment 4

16 years ago
20021008 trunk build on WIn2K
Tested with our MS Exchange 5.5 server setup for IMAP, I didn't see the alert.

Updated

16 years ago
QA Contact: huang → gchan

Comment 5

15 years ago
This pop up also appears when using Search Messages Sender, and the command
simply fails.

Comment 6

15 years ago
bug does not appear in mozilla 1.3.1 anymore. i had the same problems (mozilla
1.3, receiving imap), installed the new mozilla a few minutes ago, and it works
fine.

Comment 7

15 years ago
correcting myself: does still appear, but only when sending mails.

Comment 8

15 years ago
i resolved my problem with the error message showing up when sending mail by
simply storing the sent mails in the local folder. obviously this is some naming
conflict, because the ms exchange server names his folder "sent items" but
nagios names it "sent".
I am having similar problems. 

Everything worked fine, until today. I did not changed anything in the my
configuration (same mozilla as before, same prefs). 

The server I am trying to connect to will get an upgrade next week, so it is
either very likely or very unlikely that its configuration was changed. :-)

The error appears every time I check mail or click on the Inbox folder. In the
windows bar, I am told "1 new message" every 10 minutes, but I cannot read that
message, because when I click on Inbox, I am told an Alert message: "The current
command did not succeed. The mail server responded: One or more arguments are
invalid."

I have three concerns: 

1. Why am I told "current command"? Should it be obvious to the user what the
current command was? This should be fixed regardless of this specific bug. 

2. Why am I not told what account are we talking about? Bug #214854 might be
related to this concern. 

3. The nature of this bug should be fixed. :-) 

I am creating an attachment with the log-file. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Created attachment 143553 [details]
ecumail5.ecu.edu:143 mozilla imap:5 log

This is the IMAP:5 log from mozilla. 
I disabled my other imap accounts, and ran:

set NSPR_LOG_MODULES=IMAP:5
set NSPR_LOG_FILE=IMAP.log
cd "C:\Program Files\mozilla.org\Mozilla\"
start mozilla.exe

I opened the MailNews, waited for the error message to appear and closed
mozilla. This is the result of what appeared in IMAP.log.

UA: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.6) Gecko/20040113
Attachment #102151 - Attachment is obsolete: true

Updated

15 years ago
Assignee: mscott → bienvenu
OS: All → Linux
Hardware: All → PC
(Assignee)

Comment 11

15 years ago
Constantine, can you try a 1.7 build - that has a fix for the log getting
truncated, which it appears to be. Also, could you send me your
msgfilterrules.dat for that account? thx.

Comment 12

15 years ago
Reassigned to Default Assignee/Default OA... Fix accidental change of OS.. 
OS: Linux → All
(In reply to comment #11)
> Constantine, can you try a 1.7 build - that has a fix for the log getting
> truncated, which it appears to be. Also, could you send me your
> msgfilterrules.dat for that account? thx.

I did not yet utilised filters on that account. My
"ImapMail/ECUMAIL5/msgFilterRules.dat" has the following content: 
---
version="8"
logging="no"
---
Hardware: PC → All
(In reply to comment #11)
> Constantine, can you try a 1.7 build - that has a fix for the log getting
> truncated, which it appears to be. Also, could you send me your
> msgfilterrules.dat for that account? thx.

Was the log-file truncation fixed in 1.7a? I do not install nightly builds on my
own win32 machine...
(Assignee)

Comment 15

15 years ago
ah, thx. Looking at the log line, it's not getting truncated.  We're sending
perfectly valid protocol and the server is complaining. There's not much we can
do about that, I'm afraid. I hope the server upgrade fixes the problem...
David, could you fix my concern #1 and #2 (comment 9)? 

UPDATE: I am able to receive new messages on the account in question. But I
still get the Alert dialogue, and I am told that there is one new message. Also,
the message in question does not show up in mozilla, but does show up in the
web-mail. Is there any way to debug this problem further? 
(Assignee)

Comment 17

15 years ago
the current command is the one we execute when you select a folder, and the imap
code doesn't know neccesarily much more than that. I don't think telling you the
imap protocol we send is going to be that helpful. Re what server, yes, putting
the server name in there would be useful. Re debugging it further, you'll need
to talk to your server admin folks. My guess is that the server is failing when
we try to fetch the headers for the particular message that you can see in
webmail (which doesn't use IMAP), and that's why you can't see the message in
Mozilla. You could try deleting it in webmail, and see if the server allows you
to fetch other new messages.
(In reply to comment #17)
> the current command is the one we execute when you select a folder, and the imap
> code doesn't know neccesarily much more than that. I don't think telling you the
> imap protocol we send is going to be that helpful. Re what server, yes, putting

I think it definitely will help the end-user. Just imagine yourself in this
situation: you are trying to call the support, and they ask what problem you
have, but all you have to say is:
-- I got an Alert titled message, "The current command did not succeed. The mail
server responded: One or more arguments are invalid."
Surely, the support will have no idea what you are talking about. :-) Yes,
mozilla is for end-users, but I think, end-users would rather prefer the error
message to appear in all beauty, then to call tech support and feel like an
idiot... :-)

> the server name in there would be useful. Re debugging it further, you'll need
> to talk to your server admin folks. My guess is that the server is failing when
> we try to fetch the headers for the particular message that you can see in
> webmail (which doesn't use IMAP), and that's why you can't see the message in
> Mozilla. You could try deleting it in webmail, and see if the server allows you
> to fetch other new messages.

So, is it not Mozilla-specific problem? 

I am able to fetch other new messages. But this one does not show up. 
(Assignee)

Comment 19

15 years ago
yes, this is a server problem - the server should not be giving you this error.

If you send a server log to a server support person, they will have all the
information they need to diagnose the problem.
They've upgraded the server yesterday; I am no longer able to use the old server
and I received this message: 

"The current command did not succeed. The mail server responded: [REFERRAL
imap://cam0913d1;AUTH=*@ecustu2.intra.ecu.edu/] The requested mailbox is not
available on this server. "

I've noticed that all files with messages for this account were vanished by
mozilla from the file-system (ouch!), although I said to keep a local copy of
each folder for off-line use. (Is there a bug for this unacceptable behaviour?)

I've changed settings to the new server (ecustu2.intra.ecu.edu), everything
works fine now. That message that were producing the bug shows up in Mozilla and
I do not get any error messages. 
(Assignee)

Comment 21

15 years ago
as far as Mozilla could tell, all your folders disappeared from the server,
because the server told it there weren't any folders in that account. So we
removed them from your local machine, like we would if you had deleted the
online folders from another machine.
(In reply to comment #21)
> as far as Mozilla could tell, all your folders disappeared from the server,
> because the server told it there weren't any folders in that account. So we
> removed them from your local machine, like we would if you had deleted the
> online folders from another machine.

I set the off-line bits just for these cases --- if something happens to the
server, I will still have the messages. As far as I know, folders are not erased
when they are deleted in pop3 accounts or under some other circumstances.

FYI, I just found out that while they transferred the mail, they converted it
into quoted-printable HTML-format (ouch!), which really is not the things I'd
like to have around... Now all my messages that were text/plain are in that
format. I will miss my old text/plain messages that Mozilla didn't save. :-(
(Assignee)

Comment 23

15 years ago
We try to keep the online state (on the server) and the offline state (on your
local machine) in sync. If folders are deleted from the server, we delete them
from the client. If messages are removed on the server, we remove them on the
client. 

Pop is not a good example - POP only has one online folder, the INBOX. IMAP is
not POP.

My guess is that when your server was munged, they changed the UIDs of all your
messages on the server, if they changed the message text as well, which means
the offline stores would not have synced up with the new contents of the folders
anyway... :-(
Product: MailNews → Core

Comment 24

10 years ago
If I understand David correctly, problem is not mozilla and there is nothing more to be done.
=> INVALID
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.