Closed Bug 1732334 Opened 2 months ago Closed 2 months ago

CSS Shape Editor is broken on remote frame when Fission is enabled

Categories

(DevTools :: Inspector, defect, P3)

defect

Tracking

(Fission Milestone:Future, firefox94 verified, firefox95 verified)

VERIFIED FIXED
95 Branch
Fission Milestone Future
Tracking Status
firefox94 --- verified
firefox95 --- verified

People

(Reporter: nchevobbe, Assigned: nchevobbe)

Details

(Whiteboard: dt-perf-stability-mvp dt-fission)

Attachments

(1 file)

Steps to reproduce

  1. Go to https://ffx-devtools-css-path-editor-in-iframe.glitch.me/
  2. Right click on the orange/red part and click "Inspect"
  3. The inspector should open, and have the <div class=clipped> element selected
  4. In the rule view, click on the css shape button

Expected results

The CSS Shape Editor is displayed

Actual results

Nothing happens


Fission Milestone: --- → Future
Whiteboard: dt-perf-stability-mvp → dt-perf-stability-mvp dt-fission

Patch is on its way

Severity: -- → S3
Priority: -- → P3
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1107e4f2779f
[devtools] Fix CSS Shape Editor on iframe with dedicated target. r=jdescottes.

Backed out for causing mochitest failures.

Flags: needinfo?(nchevobbe)
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/06e2c1336902
[devtools] Fix CSS Shape Editor on iframe with dedicated target. r=jdescottes.
Flags: needinfo?(nchevobbe)
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch

The patch landed in nightly and beta is affected.
:nchevobbe, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(nchevobbe)

that's a feature that is regressed with Fission, so I guess it would be better to uplift it

Flags: needinfo?(nchevobbe)

Comment on attachment 9243254 [details]
Bug 1732334 - [devtools] Fix CSS Shape Editor on iframe with dedicated target. r=jdescottes.

Beta/Release Uplift Approval Request

  • User impact if declined: CSS Shape Editor won't work on remote iframes when Fission is enabled
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1. Go to https://ffx-devtools-css-path-editor-in-iframe.glitch.me/
  1. Right click on the orange/red part and click "Inspect"
  2. The inspector should open, and have the <div class=clipped> element selected
  3. In the rule view, click on the css shape button

-> The CSS Shape Editor is displayed

  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): DevTools only change, with automated test
  • String changes made/needed:
Attachment #9243254 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Reproduced this bug on an affected Nightly (2021-09-23), using STR from comment 0.

The issue is verified as fixed on latest Nightly 95.0a1, under macOS 11, Win 10 x64 and Ubuntu 18.04 x64.

Comment on attachment 9243254 [details]
Bug 1732334 - [devtools] Fix CSS Shape Editor on iframe with dedicated target. r=jdescottes.

Fixes a devtools regression with Fission enabled, which is expected to go to full rollout with Fx94. Approved for 94.0b8.

Attachment #9243254 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

The issue is also verified as fixed on Beta 94.0b8, under macOS 11, Win 11 x64 and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.