Closed Bug 1732460 Opened 4 months ago Closed 3 months ago

Add-on/Extension popups close immediately when attempting to interact with them on touchscreen.

Categories

(WebExtensions :: Untriaged, defect)

Firefox 92
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1696786

People

(Reporter: mail, Unassigned)

References

(Regression)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:92.0) Gecko/20100101 Firefox/92.0

Steps to reproduce:

OS: Windows 11 Insider Preview (21H2, 22000.194)
Firefox Version: 92.0.1 (64 bit)
Device: Microsoft Surface Pro 6 (i5, 8GB RAM, 256GB NVME)

  1. Open Firefox
  2. Tap (with finger) on any extension on the toolbar with a popup menu. This shows the extension's popup menu.
  3. Tap (with finger) somewhere on the (now shown) popup menu such as a button (or anywhere on the extension popup).

I am able to re-produce this in a new profile.

If the extension is pinned to the overflow menu, the issue is not present. I am able to interact with the extension normally as if using a mouse. Removing it from the overflow menu and back onto the main toolbar brings the issue back again.

Actual results:

Upon tapping somewhere on the extension popup menu, it immediately closes. I have tested other addons/extensions and all of them exhibit the same problem.

Using the mouse/trackpad to interact with the extension popup first, then using the touchscreen after allows for the extension to be interacted with normally using the touchscreen.

Expected results:

I should be able to interact with an extension's popup menu normally as if I were using a mouse.

The Bugbug bot thinks this bug should belong to the 'WebExtensions::Untriaged' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Product: Firefox → WebExtensions
Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1696786

Hello,

This appears to be the same issue as https://bugzilla.mozilla.org/show_bug.cgi?id=1696786 and will set this one as a duplicate.

In case of error, please revert the changes. Thank you !

(In reply to Clarence from comment #0)

Upon tapping somewhere on the extension popup menu, it immediately closes. I have tested other addons/extensions and all of them exhibit the same problem.

I can't reproduce on a (Lenovo with touchscreen) Windows 10 laptop, does this only reproduce in Windows 11, or is Surface necessary?

Also, I'm not sure this is a duplicate of 1696786.

Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(mail)
Resolution: DUPLICATE → ---

I've was able to replicate this issue on a clean install of Windows 10.

I've noticed that tapping around the bottom of extension's button, outside the icon (on the toolbar) allowed me to interact with it normally with the touchscreen. Tapping around the center of the button (where the icon is) presents this issue again. See image below to see what I mean.

Flags: needinfo?(mail)

(In reply to Clarence from comment #5)

I've was able to replicate this issue on a clean install of Windows 10.

I've noticed that tapping around the bottom of extension's button, outside the icon (on the toolbar) allowed me to interact with it normally with the touchscreen. Tapping around the center of the button (where the icon is) presents this issue again. See image below to see what I mean.

image link: https://imgur.com/a/38LLwwE

The severity field is not set for this bug.
:mixedpuppy, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(mixedpuppy)

Tried again and managed to reproduce time. Did a mozregression, and (unless I messed up since it's tricky), this is the regression push range:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8c4e9bba69eabce48600c6872cf3032229591fa3&tochange=f805f27183c35c40305a5deb0396182133195829

From those, bug 1682170 and bug 1493208 seem like good candidates.

Severity: -- → S3
Status: REOPENED → NEW
Flags: needinfo?(mixedpuppy)

Hey Boton, by some luck you reviewed both of those patches :), do you have an idea which one (if any) might be the cause here?

Flags: needinfo?(botond)

Bug 1493208 would be my first suspicion.

It should be easy to verify as that bug just flipped a pref: does the bug reproduce with apz.popups.enabled set to false in about:config?

Flags: needinfo?(botond)

Changing apz.popups.enabled to false fixes this defect for me. Touch interface for extension/add-on pop-up interfaces works correctly.

This is a duplicate of 1696786 (duplicate link was removed?), same config change fixes symptoms described in the original defect.

Thanks for confirming, marking this as a regression from bug 1493208.

Regressed by: 1493208

If the issue happens on popup where the content doesn't have any remote contents, https://hg.mozilla.org/integration/autoland/rev/af56e843dab2 is likely a culprit. We might need to check whether the scrollable frame has remote contents or not?

Oh, hmm I may be wrong. APZ should not be enabled for popup having no remote content.s

(In reply to Boric from comment #11)

This is a duplicate of 1696786 (duplicate link was removed?), same config change fixes symptoms described in the original defect.

Thanks, this was confirmed in bug 1696786 comment 18 as well. Let's close as a dupe (again) and take further discussion to bug 1696786.

Status: NEW → RESOLVED
Closed: 4 months ago3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1696876
Duplicate of bug: 1696786
You need to log in before you can comment on or make changes to this bug.