Closed Bug 1732461 Opened 1 year ago Closed 1 year ago

[Monochromatic Themes] The app menu update and sign in buttons have the wrong contrast on bold themes

Categories

(Firefox :: Theme, defect, P2)

Firefox 94
Desktop
All
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox94 --- affected

People

(Reporter: cbaica, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fidefe-theme])

Attachments

(1 file)

Affected versions

  • Fx94.0a1

Affected platforms

  • Windows 10
  • Ubuntu 20.04
  • macOS 10.15

Preconditions
Set browser.theme.temporary.monochromatic.enabled = true
Select a bold monochromatic theme.

Steps to reproduce

  1. Launch Firefox.
  2. Open the appmenu.
  3. Observe the sign in button contrast and compare it to [figma design].

Expected result

  • Contrast matches design.

Actual result

  • Button contrast doesn't match design.

Regression range

  • Not a regression.

Notes

  • The issue occurs for all Bold monochromatic themes.
  • Please note that if the contrast is changed, the button becomes barely visible for Cheers-bold theme.
Has STR: --- → yes
Whiteboard: [fidefe-theme]

Changing severity to S3 because this is not a critical accessibility contrast issue.

Severity: S2 → S3
Priority: -- → P2

I'm going to close this as WONTFIX. The spec and Firefox's Dark theme use a custom color value for these types of buttons. All other themes use a default value. This default value uses currentColor, so the background color inherits some of the theme's color. You can see this especially in the Bold themes: button background colors are tinted the color of the theme. Using the custom color in the spec means buttons wouldn't match the rest of the theme. It would also mean the new themes would have to use even more experimental custom theme properties not available to third-party theme developers. This makes the themes harder to maintain and is something we're trying to avoid.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.