If User-Agent string is not the real useragent, java-plugin displays error each time all windows are closed (turbo?)

VERIFIED DUPLICATE of bug 83376

Status

defect
VERIFIED DUPLICATE of bug 83376
17 years ago
9 years ago

People

(Reporter: bugzilla, Assigned: joe.chou)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2b) Gecko/20021003
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2b) Gecko/20021003

I've set the Useragent-string to WinXP-IE6 to test Evangelism issues with the
preferences-bar available from http://www.xulplanet.com/downloads/prefbar/, and
then noticed, when closing the last open window, a small dialog-box saying
something like:

"Java plug-ing for Netscape should not be used in MS Internet Explorer. Please
use Java Plugin for MSIE instead".

When i changed the UA-string back, the 'problem' went away.

I don't get why Mozilla tries to start the Java-plugin when all windows are closed. 

I tried once to restart mozilla before closing that window, causing it to hang,
and I had to kill it.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

17 years ago
IMHO, Java is not even supposed to work correctly (i.e. could crash) when
modifying UA, see bug 83376.

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 83376 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: joe.chou → petersen
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.