Closed Bug 1732549 Opened 11 months ago Closed 11 months ago

Startup Crash using newsgroup after View > Threads > Unread

Categories

(Thunderbird :: General, defect)

Thunderbird 88
Unspecified
All
defect

Tracking

(thunderbird_esr91+ verified)

RESOLVED FIXED
94 Branch
Tracking Status
thunderbird_esr91 + verified

People

(Reporter: wsmwk, Assigned: mkmelin)

References

(Blocks 3 open bugs, )

Details

(4 keywords)

Crash Data

Attachments

(1 file)

  1. Use Version 91 or 93.
  2. click on a newsgroup
  3. View > Threads > Unread

Results:

  • Mac terminal shows "Exiting due to channel error."
  • Crash reporter
  • Crash reporter fails - "There was a problem submitting your report" - perhaps because of OOM?

This is reported by Windows user in Newsgroups: alt.comp.software.thunderbird Subject: Upgrade to 91.1.1 doesn't like my NNTP server

Flags: needinfo?(mkmelin+mozilla)

(Sancus fixed the crash reporting problem.)

There are several choices on the "View > Thread", "Unread" is the ONLY one which crashes. Earliest crash I found is version 88 buildid 20210412182002 bp-a60173f9-56bb-4d3d-a70d-c94100210418

nsMsgThreadedDBView::InitThreadedView bp-0dfdd86d-78a8-46f3-b7f3-83cfd0210926 my crash on Mac with 93 beta

Crash Signature: [@ nsMsgThreadedDBView::InitThreadedView ]
Version: Thunderbird 91 → Thunderbird 88
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Flags: needinfo?(mkmelin+mozilla)

But the WantsThisThread() call should basically fix it.
I can't reproduce the crash so there must some other factor playing in as well.

Ah, but that checks threadHdr not msgHdr.

See Also: → 1732816

Changing severity to S3 because not a common crash.

Severity: S2 → S3
OS: Unspecified → All

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/bd04c2bb4b2d
fix Crash using newsgroup after View > Threads > Unread. r=benc

Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch

Comment on attachment 9242990 [details]
Bug 1732549 - fix Crash using newsgroup after View > Threads > Unread. r=benc

[Approval Request Comment]
Crash fix, fairly safe.

Attachment #9242990 - Flags: approval-comm-esr91?

Comment on attachment 9242990 [details]
Bug 1732549 - fix Crash using newsgroup after View > Threads > Unread. r=benc

[Triage Comment]
Approved for esr91

Attachment #9242990 - Flags: approval-comm-esr91? → approval-comm-esr91+
Summary: Crash using newsgroup after View > Threads > Unread → Startup Crash using newsgroup after View > Threads > Unread
Blocks: 1735822

I can see in crash-stats there are no reports from 91.2.1, so v.fixed

You need to log in before you can comment on or make changes to this bug.