Closed Bug 1732692 Opened 4 months ago Closed 3 months ago

[Monochromatic Themes] Residual line is displayed between tab bar and toolbar

Categories

(Firefox :: Theme, defect, P1)

Firefox 94
Desktop
Windows 10
defect
Points:
1

Tracking

()

VERIFIED FIXED
95 Branch
Iteration:
95.1 - Oct 4 - Oct 17
Tracking Status
firefox94 --- verified
firefox95 --- verified

People

(Reporter: cbaica, Assigned: bugzilla)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [fidefe-theme])

Attachments

(3 files)

Affected versions

  • Fx94.0a1

Affected platforms

  • Windows 10
  • Ubuntu 20.04

Preconditions
Set browser.theme.temporary.monochromatic.enabled = true
Select any monochromatic theme.

Steps to reproduce

  1. Launch Firefox.
  2. Observe the tab bar and the toolbar.

Expected result

  • There is no 'separator', the color change is done directly.

Actual result

  • There is a residual line separating the tab bar from the toolbar.

Regression range

  • Not a regression.

Additional notes

  • Please note that the issue occurs with all the monochromatic themes.
  • The 'old' themes (Default, Light, Dark and Alpenglow) don't have this issue.
Blocks: 1731038, 1725467
Has STR: --- → yes
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1732173

We need to set toolbar_top_separator: "transparent" in the theme manifests.

Status: RESOLVED → REOPENED
Points: --- → 1
Priority: -- → P1
Resolution: DUPLICATE → ---
Whiteboard: [fidefe-theme]
Assignee: nobody → htwyford
Status: REOPENED → ASSIGNED
Iteration: --- → 95.1 - Oct 4 - Oct 17
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/38463ee0a61f
Set toolbar_top_separator to transparent. r=dao

Comment on attachment 9244818 [details]
Bug 1732692 - Set toolbar_top_separator to transparent. r?dao,amy

Beta/Release Uplift Approval Request

  • User impact if declined: Visual bug of a residual line between tab bar and toolbar.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): CSS-only change.
  • String changes made/needed:
Attachment #9244818 - Flags: approval-mozilla-beta?
Status: ASSIGNED → RESOLVED
Closed: 4 months ago3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch

Comment on attachment 9244818 [details]
Bug 1732692 - Set toolbar_top_separator to transparent. r?dao,amy

Approved for 94.0b4.

Attachment #9244818 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

The issue is still reproducible with Lush-Balanced theme, on Windows 10 an Ubuntu 20.04.

All the other themes are fixed. The separator is no longer visible. In both nightly and beta build.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/132d9b4f70ed
Set toolbar_top_separator to transparent for lush balanced theme. r=dao,harry
Status: REOPENED → RESOLVED
Closed: 3 months ago3 months ago
Resolution: --- → FIXED

The issue is verified fixed in latest nightly on Windows 10 and Ubuntu 20.04. Waiting for the uplift to close out the issue as verified fixed.

Amy, could you please request uplift on your additional patch?

Flags: needinfo?(achurchwell)

Comment on attachment 9245347 [details]
Bug 1732692 - Set toolbar_top_separator to transparent for lush balanced theme. r?dao,harry

Beta/Release Uplift Approval Request

  • User impact if declined: Visual bug of a residual line between tab bar and toolbar.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): CSS-only change.
  • String changes made/needed:
Flags: needinfo?(achurchwell)
Attachment #9245347 - Flags: approval-mozilla-beta?

Comment on attachment 9245347 [details]
Bug 1732692 - Set toolbar_top_separator to transparent for lush balanced theme. r?dao,harry

Approved for 94.0b8, thanks.

Attachment #9245347 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I can confirm this issue is fixed, I verified using Firefox 94.0b9 and 95.0b4, on Win 10 x64, Ubuntu 20.04 x64 and macOS 10.15.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.