Closed Bug 1732753 Opened 11 months ago Closed 11 months ago

Events not printed - monthly

Categories

(Calendar :: Printing, defect)

Thunderbird 91
defect

Tracking

(thunderbird_esr91 verified)

VERIFIED FIXED
94 Branch
Tracking Status
thunderbird_esr91 --- verified

People

(Reporter: FKlusmann, Assigned: darktrojan)

References

(Blocks 1 open bug, Regression)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:92.0) Gecko/20100101 Firefox/92.0

Steps to reproduce:

Have an event in the last and prior week of the month to be printed.
For example, meetings every Tuesday and Thursday.
Print the month in the monthly grid format.
For example, October of 2021.

Actual results:

September 28 and 30 are left blank.
November 2 and 4 are left blank.

Expected results:

In the past, everything was printed. I expect to replace (on a peg-board) last month's calendar page with the new one without losing the entries in the last week of this month (or the first week of the coming month).

Note that this could lead to safety items being missed if the printed calendar is replaced during the last week of a month.

I have 91.1.1. I downloaded this because my prior version refused to open for me.

And several other annoyances:

  • All views now have a title so something intelligent can be used as a file name when printing to file.
  • Fix the week view where the start-of-week preference is not Monday.
Assignee: nobody → geoff

It was a deliberate decision not to print the events outside the month selected. In hindsight though I think it was a bad decision, so I've reversed it.

Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/1171dc912ce1
Fix printing calendar events in adjacent months to that being printed. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch

(In reply to Geoff Lankow (:darktrojan) from comment #3)

It was a deliberate decision not to print the events outside the month selected. In hindsight though I think it was a bad decision, so I've reversed it.

Through what process are these decisions made?

The calculated last day was wrong in two ways:

  • It was based on the first day after the month to be printed, so the value could be a week later than needed. This wouldn't be a problem, except that it covered up the other problem.
  • I didn't add a day, so events on the last day weren't displayed. (Because the end-of-week value was 00:00 of the last day, getItems didn't return items ON the last day.)

Reopening, to fix a calculation mistake.

(In reply to Worcester12345 from comment #5)

Through what process are these decisions made?

I think "Is this what it should do?", and then I think "Yes, this is what it should do.".

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

(In reply to Geoff Lankow (:darktrojan) from comment #7)

Reopening, to fix a calculation mistake.

(In reply to Worcester12345 from comment #5)

Through what process are these decisions made?

I think "Is this what it should do?", and then I think "Yes, this is what it should do.".

So, no real process, or user driven group driving this, just one man's personal opinion. Got it. Thanks anyhow.

Right. The man employed by the council elected by the users to make decisions like this one, so that we don't have to go through a tedious consultation process over every little thing. If you don't like the decisions I make, you can request that I reconsider them just like the reporter of this bug has done.

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/18283be347b7
follow-up - Fix events shown on the last day of a printed month. r=mkmelin

Status: REOPENED → RESOLVED
Closed: 11 months ago11 months ago
Resolution: --- → FIXED

Thank you, Geoff Lankow (:darktrojan)
How does a user (ME) get the fix? I don't know enough to try with the code.
Updating to 91.1.2 did not include the fix.
Thanks.

Flags: needinfo?(geoff)

Correct, the fix has only made it to our development channel at the moment. It'll go to our beta channel next week and from there I'll get it to the release channel ASAP. Probably 91.2.1 in two-three weeks. (Sorry it doesn't happen much faster than that, we have to make sure everything is safe to release before we send it to millions of users.)

Flags: needinfo?(geoff)

Comment on attachment 9243150 [details]
Bug 1732753 - Fix printing calendar events in adjacent months to that being printed. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): bug 1713045, I guess
User impact if declined: some events are not printed when the user might expect them to be
Testing completed (on c-c, etc.): in 94.0b1
Risk to taking this patch (and alternatives if risky): low

There's a follow-up patch which also needs to be uplifted.

Attachment #9243150 - Flags: approval-comm-esr91?

Comment on attachment 9243150 [details]
Bug 1732753 - Fix printing calendar events in adjacent months to that being printed. r=mkmelin

[Triage Comment]
Approved for esr91

Note two patches

Flags: needinfo?(rob)
Attachment #9243150 - Flags: approval-comm-esr91? → approval-comm-esr91+

Comment on attachment 9243351 [details]
Bug 1732753 follow-up - Fix events shown on the last day of a printed month. r=mkmelin

[Triage Comment]
Approved for esr91

Attachment #9243351 - Flags: approval-comm-esr91+
Flags: needinfo?(rob)

Verified fixed testing the 91.2.1 release candidate on Windows 10 when printed in Portrait mode with Scale set to "Fit to page width". Needed to set Scale on my system to 80% to get a one page print out in Landscape mode.

I am presuming this bug report was about Portrait mode.

Status: RESOLVED → VERIFIED
Regressed by: 1713045
You need to log in before you can comment on or make changes to this bug.