Closed Bug 173287 Opened 17 years ago Closed 17 years ago

Patch for compiler warning in 'Navigation.mm' - const string

Categories

(Camino Graveyard :: General, defect, minor)

PowerPC
macOS
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 202716

People

(Reporter: bfowler, Assigned: sfraser_bugs)

Details

Index: PreferencePanes/Navigation/Navigation.mm
===================================================================
RCS file: /cvsroot/mozilla/chimera/PreferencePanes/Navigation/Navigation.mm,v
retrieving revision 1.10.2.3
diff -u -2 -r1.10.2.3 Navigation.mm
--- PreferencePanes/Navigation/Navigation.mm	2 Oct 2002 07:10:20 -0000	1.10.2.3
+++ PreferencePanes/Navigation/Navigation.mm	8 Oct 2002 16:10:16 -0000
@@ -36,5 +36,5 @@
 @interface OrgMozillaChimeraPreferenceNavigation(Private)
 
-- (NSString*)getInternetConfigString:(Str255)icPref;
+- (NSString*)getInternetConfigString:(const Str255)icPref;
 
 @end
@@ -198,5 +198,5 @@
 }
 
-- (NSString*)getInternetConfigString:(Str255)icPref
+- (NSString*)getInternetConfigString:(const Str255)icPref
 {
   NSString*     resultString = @"";

This function does not alter its parameter, which should therefore be declared const. This also
saves warning when it is called with a doubled quoted string.
Ben, please also attach this patch. Thanks.
Keywords: patch, review
Taking
Assignee: saari → sfraser
Status: UNCONFIRMED → NEW
Ever confirmed: true
Resolving dup per bug 202716, comment 4.

*** This bug has been marked as a duplicate of 202716 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.