Closed Bug 1732906 Opened 4 months ago Closed 4 months ago

browser_rules_eyedropper.js is failing with EFT enabled

Categories

(DevTools :: Inspector, task)

task

Tracking

(firefox95 fixed)

RESOLVED FIXED
95 Branch
Tracking Status
firefox95 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

Details

(Whiteboard: dt-perf-stability-mvp)

Attachments

(1 file)

A call to isXul while the eyedropper gets hidden is throwing, making the test fail.

With EFT, tests using the eyedropper were failing because of the isXul check
done when the eyedropper gets hidden: the document.documentElement property
was null at this point and the isXul method was throwing.
This patch replace the isXul check with a check on the presence of an abortController
property, which we do now set in the show method.

Depends on D126807

Whiteboard: dt-perf-stability-mvp
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f2419a8c8c5f
[devtools] Refactor eyedropper show/hide methods. r=ochameau.

Backed out for causing mochitest failures.

Flags: needinfo?(nchevobbe)
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2648d026f172
[devtools] Refactor eyedropper show/hide methods. r=ochameau.
Flags: needinfo?(nchevobbe)
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
Regressions: 1741797
You need to log in before you can comment on or make changes to this bug.