Closed Bug 1732969 Opened 2 months ago Closed 2 months ago

[macOS] Prompt to install to disk on every run from .dmg

Categories

(Toolkit :: Startup and Profile System, enhancement, P2)

enhancement

Tracking

()

VERIFIED FIXED
94 Branch
Tracking Status
firefox94 --- verified

People

(Reporter: spohl, Assigned: spohl)

References

Details

Attachments

(1 file)

Since running from a .dmg is not technically supported and can result in loss of data (such as bookmarks, browsing history etc.) it would seem that we should suggest to install Firefox to disk on every run from .dmg, not only on first run.

Pushed by spohl@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/85f046764f9c
Start prompting to install every time that we detect that we're running from a .dmg disk image on macOS, not only on first run. r=mstange
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch
Flags: qe-verify+
Duplicate of this bug: 1729637

Verified fixed with Firefox 94.0b9 (20211021185848) on macOS 11.6 ARM and macOS 10.15. The prompt to install is displayed every time when Firefox is opened from the .dmg image.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.