Closed Bug 1733002 Opened 4 months ago Closed 4 months ago

Consider Never Automatically Unloading WebRTC Tabs

Categories

(Firefox :: Tabbed Browser, defect)

defect

Tracking

()

RESOLVED FIXED
95 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox92 --- unaffected
firefox93 + wontfix
firefox94 --- fixed
firefox95 --- fixed

People

(Reporter: haik, Assigned: toshi)

References

Details

Attachments

(1 file)

Automatically unloading a WebRTC tab seems likely to be an annoyance for users because it will cause users to be disconnected from their calls and possibly miss important information. This is different from typical sites and most video sites that are easily restored to their previous state. Although this has not been a problem on Nightly and Beta so far, it could be a problem when we ship tab unloading to release in 93.

It's not clear to me how much of a risk this for release. If we had to uplift a fix to prevent WebRTC tabs from being unloaded, I expect it would be a small change to have usingWebRTC() return NEVER_DISCARD.

See Also: → 1733087
Blocks: 1587762

[Tracking Requested - why for this release]:
Unloading WebRTC tabs might be a problem on release that we have to issue a dot release fix for. Users could be frustrated by WebRTC disconnections.

Assignee: nobody → tkikuchi
Status: NEW → ASSIGNED

Pascal and/or Dianna, can this make 93?

Flags: needinfo?(pascalc)
Flags: needinfo?(dsmith)

(In reply to Haik Aftandilian [:haik] from comment #3)

Pascal and/or Dianna, can this make 93?

No, we ship tomorrow, the only possibility at this point would be to have a dot release before 94 ships.

Flags: needinfo?(pascalc)
See Also: → 1734099
Pushed by tkikuchi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/54e78f8e35de
Never discard tabs playing sound, using WebRTC, or using PiP.  r=haik
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
Duplicate of this bug: 1733087

Please nominate this for Beta approval when you get a chance.

Flags: needinfo?(dsmith) → needinfo?(tkikuchi)

Comment on attachment 9243760 [details]
Bug 1733002 - Never discard tabs playing sound, using WebRTC, or using PiP. r=haik

Beta/Release Uplift Approval Request

  • User impact if declined: Firefox may unload a tab playing sound or using webrtc if it has the highest priority i.e. all other tabs also use webrtc or in the foreground. Such a behavior disrupts users' browsing experience.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This patch updates scores of special attributes (playing media, using webrtc, etc.) with the special value meaning non-discardable. No logic is changed.
  • String changes made/needed: None
Flags: needinfo?(tkikuchi)
Attachment #9243760 - Flags: approval-mozilla-release?
Attachment #9243760 - Flags: approval-mozilla-beta?

Comment on attachment 9243760 [details]
Bug 1733002 - Never discard tabs playing sound, using WebRTC, or using PiP. r=haik

Approved for 94.0b3.

Attachment #9243760 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment on attachment 9243760 [details]
Bug 1733002 - Never discard tabs playing sound, using WebRTC, or using PiP. r=haik

We won't be building a 93.0.1 release. This change will ride 94.

Attachment #9243760 - Flags: approval-mozilla-release? → approval-mozilla-release-
You need to log in before you can comment on or make changes to this bug.