Closed Bug 1733039 Opened 4 months ago Closed 4 months ago

Selected node in remote iframe is not selected back after reload when Fission is enabled

Categories

(DevTools :: Inspector, defect, P3)

defect

Tracking

(firefox95 fixed)

RESOLVED FIXED
95 Branch
Tracking Status
firefox95 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

Details

(Whiteboard: dt-perf-stability-mvp, dt-fission)

Attachments

(1 file)

Steps to reproduce

  1. Open a tab with data:text/html,<meta charset=utf8><iframe src="https://example.com"></iframe>
  2. Right click on the "Example domain" and select "Inspect"
  3. The <h1> node, inside the iframe, should be selected
  4. Reload the page

Expected results

The <h1> node is selected again

Actual results

The <h1> node is not selected again


This is caused by the WalkerFront's findNodeFront method, which always use the top level walker to querySelector [1], where it should use the walker from the nodeFront at hand

[1] https://searchfox.org/mozilla-central/rev/8db61933e64b13c4a0ae456bcaccbd86a519ccc5/devtools/client/fronts/walker.js#410

The top-level target walker was used to find elements, where we should use the
walker front of the nodeFront we have at hand.
The function was also checking if the node we're searching was associated with
this walker, which, with EFT, won't be the case as soon as we have to go through
an iframe.

Depends on D126808

pretty harmless, S3

Severity: -- → S3
Priority: -- → P3
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bf18a96d849f
[devtools] Fix walkerFront#findNodeFront method for EFT/Fission. r=ochameau.

Backed out for causing mochitest failures.

Flags: needinfo?(nchevobbe)
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3d7ded347278
[devtools] Fix walkerFront#findNodeFront method for EFT/Fission. r=ochameau.
Flags: needinfo?(nchevobbe)
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
You need to log in before you can comment on or make changes to this bug.