flash games display problem (pheonix specific)

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
16 years ago
15 years ago

People

(Reporter: mbond, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
We noticed a problem today where some of the java games in neoppets do not
display correctly. They seem to be playable, but the placement of objects are
off. I originally though that this was a problem with either the java or
mozilla's rendering engine, but when we tried it again using Mozilla 1.0.1, the
problem was not there. 

The problem also does not occure in the Galeon on Linux. I'm not sure exactly
where the fluke is, but it is only reproducable in Pheonix.

The Pheonix version is 0.2
I don't know how to get to the specific games in neopets where the problem is
occuring (and i know you need a user account), it is installed on a users
computer who has been willing to attempt an Open Source replacement to several
programs.

Comment 1

16 years ago
Testing mozilla 1.0.1 is not sufficient to rule out this being a Mozilla
problem. There have been tens of thousands of lines of code changed on the trunk
since 1.0.1. These are the builds to use when testing to see if it's a Mozilla
or a Phoenix problem http://ftp.mozilla.org/pub/mozilla/nightly/latest-trunk/

Comment 2

16 years ago
Also you need to ensure that the same version of the JRE (Java Runtime
Environment plugin) is running in Phoenix and in Mozilla, as badly-written code
that works in Java 2 1.4.0 can break in the latest JRE, 1.4.1 (as I have found
out myself)

Comment 3

16 years ago
After digging through http://neopets.com for a while I was unable to find any
Java games.  I found Javascript and Flash games, all of which worked fine in:

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021021 Phoenix/0.3

I have the latest Flash 6 plugin and JRE 1.4.0 (not that I used it).

Could the Reporter specify which games do not display correctly?  Also include
specifics about which visual elements are misplaced, JRE version (if this is
Java and not Javascript), etc. please.

I understand that the reporter does't know te URL, but even the NAME of the
game(s) would be helpful.

I suspect this is a Javascript and not a Java issue as the user is unlikely to
have both 1.4.0 and 1.4.1 on the system.  A single Java RE should display an
applet the same way in every browser, since the plugin handles all drawing in
its area.  There have been Javascript changes between Mozilla 1.0.1 and Phoenix
0.2, making different behaviors more likely.

The questions now are "Does this bug stll exist?" and "Does it effect recent
Mozilla builds as well?".

Comment 4

16 years ago
I think this is now a worksforme using Mozilla/5.0 (Windows; U; Win98; en-US;
rv:1.2b) Gecko/20021023 Phoenix/0.3

I know the bug that the reporter was talking about... flash games wouldn't
display, for any game you chose you'd end up getting a blank screen (loading the
url in a fresh start of phoenix would work, but not in the popup windows). But
for some reason it works perfectly using the newer phoenix builds, and I havn't
seen any flash bugs at all recently. Hopefully someone else can confirm running
into this bug as well, and that it now works.

Comment 5

16 years ago
Just for clarification, this is a flash not a java bug, there is no java used on
neopets.com, aside from javascript.

Comment 6

16 years ago
resolving as worksforme. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Summary: java display problem (pheonix specific) → flash games display problem (pheonix specific)

Comment 7

15 years ago
VERIFIED Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030721
Mozilla Firebird/0.6
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.