Message Filter Rules doesn't hold user input in Editing

VERIFIED FIXED

Status

MailNews Core
Filters
VERIFIED FIXED
15 years ago
9 years ago

People

(Reporter: yulian chang, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt1])

Attachments

(1 attachment)

588 bytes, patch
(not reading, please use seth@sspitzer.org instead)
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

15 years ago
20021008 trunk build on Win2K

reproducible: always

1. Tools | Message Filters menu item to open Message Filters dialog
2. Select one Filter Name to Edit
3. In Filter Rules dialog, for incoming messages that Match all/Any of the following

Actual results: The user input data for the chosen rule disappears. For example,
The Subject contains '    '.

Expected results: User input should hold. For example, The Subject contains 'test'.

It's a regression. Oct02 trunk build has no problem.
(Reporter)

Comment 1

15 years ago
The problem happens in Trunk build only.
Nominating for Buffy
Keywords: nsbeta1
Summary: User input in Message Filter Rules displayed blank in editing → Message Filter Rules doesn't hold user input in Editing

Comment 2

15 years ago
We need to fix this asap.  It should be in 1.2beta.
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt1]

Comment 3

15 years ago
*** Bug 173472 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

15 years ago
I'll take a look. 
Status: NEW → ASSIGNED
(Assignee)

Comment 5

15 years ago
Created attachment 102507 [details] [diff] [review]
proposed fix

Looks like this got deleted by mistake by sspitzer

checkin that caused this

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=mailWidgets.xml&root=/cvsroot&subdir=mozilla/mailnews/base/resources/content&command=DIFF_FRAMESET&rev1=1.47&rev2=1.48
Comment on attachment 102507 [details] [diff] [review]
proposed fix

r/sr=sspitzer

yes, that was on accident.

thanks for catching my mistake.
Attachment #102507 - Flags: superreview+
Attachment #102507 - Flags: review+

Comment 7

15 years ago
Comment on attachment 102507 [details] [diff] [review]
proposed fix

a=asa for checkin to 1.2beata (on behalf of drivers)
Attachment #102507 - Flags: approval+
(Assignee)

Comment 8

15 years ago
fixed 
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 9

15 years ago
Marking verified.
OK using oct11 commercial trunk builds: win98, mac OS 10.1, linux rh6.2
Status: RESOLVED → VERIFIED

Comment 10

15 years ago
*** Bug 174209 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.