linux debug build crash with context menu on menupopup

RESOLVED WORKSFORME

Status

()

Firefox
Menus
--
critical
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Pierre Chanial, Unassigned)

Tracking

({crash, testcase})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

1.69 KB, application/vnd.mozilla.xul+xml
Details
3.21 KB, text/plain
Details
(Reporter)

Description

16 years ago
steps to reproduce:
- load test that will follow
- lclick on "Open me'
- rclick on "Menu item one'
- type ESC
(Reporter)

Comment 1

16 years ago
Created attachment 102216 [details]
test case
(Reporter)

Comment 2

16 years ago
Created attachment 102217 [details]
stack

Comment 3

16 years ago
WFT with a build from today on Linux. When I do the right-click a context menu
appears and when I then hit ESC the context menu is removed. No crash.

Updated

16 years ago
Keywords: crash

Comment 4

16 years ago
By the definitions on <http://bugzilla.mozilla.org/bug_status.html#severity> and
<http://bugzilla.mozilla.org/enter_bug.cgi?format=guided>, crashing and dataloss
bugs are of critical or possibly higher severity.  Only changing open bugs to
minimize unnecessary spam.  Keywords to trigger this would be crash, topcrash,
topcrash+, zt4newcrash, dataloss.
Severity: normal → critical
(Reporter)

Comment 5

16 years ago
I can't reproduce this bug anymore.
Someone still seeing it?

Comment 6

15 years ago
not me...
(Reporter)

Comment 7

15 years ago
yes, I should have mentionned it only happens with debug builds.
updating summary
Summary: linux crash with context menu on menupopup → linux debug build crash with context menu on menupopup

Updated

15 years ago
Target Milestone: --- → After Firebird 1.0

Comment 8

15 years ago
Taking QA Contact as designated owner of Firebird-Menus. Sorry for bugspam.
QA Contact: asa → bugzilla

Comment 9

15 years ago
Pierre, are you still seeing this? It's been a long time since March 2003.
(Reporter)

Comment 10

15 years ago
yes, that's a debug only bug.

Comment 11

14 years ago
Hi,
 I cannot reproduce this with current cvs build with debug enabled and no
optimization on Linux.

Updated

13 years ago
Assignee: hyatt → nobody
QA Contact: bugzilla → menus
Target Milestone: Future → ---

Comment 12

12 years ago
bug verified
bug non-existant on windows/mac byt linux yes.
Keywords: testcase

Comment 13

9 years ago
WFM.  I can't get my debug build to crash on Ubuntu 9.10.

Built from http://hg.mozilla.org/mozilla-central/rev/0d98ff9aef32
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.