Closed Bug 1733413 Opened 4 months ago Closed 4 months ago

Permanent several tests forms/input/file/simple.html == forms/input/file/simple-ref.xhtml | image comparison, max difference: 254, number of differing pixels: 628 when Gecko 94 merges to Beta on 2021-10-04

Categories

(Core :: Layout: Form Controls, defect, P5)

defect

Tracking

()

RESOLVED FIXED
95 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox92 --- unaffected
firefox93 --- unaffected
firefox94 + fixed
firefox95 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: emilio)

References

(Regressed 1 open bug)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: archaeopteryx [at] coole-files.de
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=353239738&repo=try
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/Vh8oOgzaQPOd9cEALNBIGQ/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/Vh8oOgzaQPOd9cEALNBIGQ/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


	13:38:37 INFO - REFTEST TEST-UNEXPECTED-FAIL | layout/reftests/forms/input/file/simple.html == layout/reftests/forms/input/file/simple-ref.xhtml | image comparison, max difference: 254, number of differing pixels: 628
10514	13:38:37 INFO - REFTEST TEST-UNEXPECTED-FAIL | layout/reftests/forms/input/file/rtl.html == layout/reftests/forms/input/file/rtl-ref.xhtml | image comparison, max difference: 254, number of differing pixels: 318
10521	13:38:37 INFO - REFTEST TEST-UNEXPECTED-FAIL | layout/reftests/forms/input/file/size.html == layout/reftests/forms/input/file/simple-ref.xhtml | image comparison, max difference: 254, number of differing pixels: 628
10530	13:38:37 INFO - REFTEST TEST-UNEXPECTED-FAIL | layout/reftests/forms/input/file/background.html == layout/reftests/forms/input/file/background-ref.xhtml | image comparison, max difference: 254, number of differing pixels: 314
10538	13:38:38 INFO - REFTEST TEST-UNEXPECTED-FAIL | layout/reftests/forms/input/file/style.html == layout/reftests/forms/input/file/style-ref.xhtml | image comparison, max difference: 254, number of differing pixels: 314

https://treeherder.mozilla.org/logviewer?job_id=353239741&repo=try also has
REFTEST TEST-UNEXPECTED-FAIL | layout/reftests/writing-mode/ua-style-sheet-button-1.html == layout/reftests/writing-mode/ua-style-sheet-button-1a-ref.html | image comparison, max difference: 254, number of differing pixels: 9080
REFTEST TEST-UNEXPECTED-FAIL | layout/reftests/writing-mode/ua-style-sheet-input-color-1.html == layout/reftests/writing-mode/ua-style-sheet-input-color-1-ref.html | image comparison, max difference: 198, number of differing pixels: 1704

Duplicate(s) of bug 1733354?

Flags: needinfo?(emilio)
See Also: → 1733398, 1733354

Yeah, though it's a bit odd that we're using dark system colors there. Anyhow bug 1733354 will fix.

Status: NEW → RESOLVED
Closed: 4 months ago
Flags: needinfo?(emilio)
Resolution: --- → DUPLICATE
Duplicate of bug: 1733354

It's still an issue.

Status: RESOLVED → REOPENED
Flags: needinfo?(emilio)
Resolution: DUPLICATE → ---
Summary: Intermittent several tests forms/input/file/simple.html == forms/input/file/simple-ref.xhtml | image comparison, max difference: 254, number of differing pixels: 628 → Permanent several tests forms/input/file/simple.html == forms/input/file/simple-ref.xhtml | image comparison, max difference: 254, number of differing pixels: 628 when Gecko 94 merges to Beta on 2021-10-04

I'm really confused about this. Let me try to guess how to reproduce locally or something.

Ohh, they're comparing with a chrome:// URI and IIRC dev-edition uses a dark theme by default, which would explain this.

Assignee: nobody → emilio
Flags: needinfo?(emilio)

In the future we need to remove this patch, implement dark form
controls, and probably make those tests pass some other way (like
forcing the chrome color-scheme to match content for those tests or
something). Otherwise they are really expected to fail on a Firefox dark
theme.

But this is a somewhat-easy fix for now.

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/eaed626461db
Force light color-scheme for non-native-theme docs for now. r=mstange

Please request uplift to beta (Gecko 94).

Flags: needinfo?(emilio)

Comment on attachment 9244236 [details]
Bug 1733413 - Force light color-scheme for non-native-theme docs for now. r=mstange

Beta/Release Uplift Approval Request

  • User impact if declined: None
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: none
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This only affects chrome documents that use the non-native theme with a dark firefox theme.
  • String changes made/needed: none
Flags: needinfo?(emilio)
Attachment #9244236 - Flags: approval-mozilla-beta?
Status: REOPENED → RESOLVED
Closed: 4 months ago4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch

Comment on attachment 9244236 [details]
Bug 1733413 - Force light color-scheme for non-native-theme docs for now. r=mstange

Approved for 94.0b2.

Attachment #9244236 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Regressed by bug 1731678 I think.

Blocks: 1735800
Regressions: 1742299
You need to log in before you can comment on or make changes to this bug.