Closed Bug 1733421 Opened 4 months ago Closed 3 months ago

Browser Toolbox doesn't jump to element in tree on in-content pages

Categories

(DevTools :: Inspector, defect, P2)

defect

Tracking

(firefox-esr78 unaffected, firefox-esr91 unaffected, firefox93 unaffected, firefox94 verified, firefox95 verified)

VERIFIED FIXED
95 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox93 --- unaffected
firefox94 --- verified
firefox95 --- verified

People

(Reporter: Paenglab, Assigned: nchevobbe)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Bug 1732966 fixed the issue that the Browser Toolbox doesn't highlight elements in in-content pages like the prefs.

But now it doesn't jump to the element in the tree. The rules view shows the correct rules.

On normal web pages all is working correctly.

Flags: needinfo?(nchevobbe)

Do you have a test case Richard? I quickly checked on Nightly and everything seems fine

Flags: needinfo?(nchevobbe) → needinfo?(richard.marti)
Summary: Browser Toolbos doesn't jump to element in tree on in-content pages → Browser Toolbox doesn't jump to element in tree on in-content pages

STR:

  • Open Browser Toolbox
  • Open the Settings
  • Click in Browser Toolbox the pick an element button and click on an element in the Settings like a checkbox

Result: On the right of the Browser Toolbox in Rules the rules for checkbox are shown but on the left the tree doesn't jump to the element. Below the breadcrumbs shows the correct path.

Flags: needinfo?(richard.marti)

I meant the FX settings not the Browser Toolbox settings.

Ah yes, thanks, I'm looking into this

This patch sort of reverts to what existed before Bug 1731996, except
that we still handle hovering on iframe padding.

The "refactoring" that was done in Bug 1731996 made the Browser Toolbox nodePicker
misbehaving.
Unfortunately, it's hard to have a test for the Browser Toolbox nodePicker, as
when we use BrowserTestUtils.synthesizeMouse we explicitely pass the window
we want the event to happen in so we don't hit any of the propagation stopper
that might occur when using it manually.

Depends on D127224

Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Severity: -- → S3
Priority: -- → P2
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/60c5ef76eb44
[devtools] Fix BrowserToolbox node picker. r=ochameau.
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
Duplicate of this bug: 1735387

Should we ask for an uplift?

Flags: needinfo?(nchevobbe)
Regressed by: 1731996

(In reply to Julian Descottes [:jdescottes] from comment #9)

Should we ask for an uplift?

Yes, that would be better I guess

Flags: needinfo?(nchevobbe)

Comment on attachment 9244342 [details]
Bug 1733421 - [devtools] Fix BrowserToolbox node picker. r=ochameau.

Beta/Release Uplift Approval Request

  • User impact if declined: Using the Browser Toolbox , the node picker won't work properly on pages like about:preferences, or for inspecting chrome documents (e.g. devtools panels)
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1. In Firefox, open DevTools inspector on a page of your choice
  1. Open the MultiProcess Browser Toolbox
  2. Select the node picker
  3. Try to select an element in the inspector markup view
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): DevTools/Browser Toolbox fix only, only impacting node picker behavior, which is not something regular users are using
  • String changes made/needed:
Attachment #9244342 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Reproduced this bug on an affected Nightly (2021-09-30), using STR from comment 2.

The issue is verified as fixed on latest Nightly 95.0a1, under macOS 11, Win 10 x64 and Ubuntu 18.04 x64.

Comment on attachment 9244342 [details]
Bug 1733421 - [devtools] Fix BrowserToolbox node picker. r=ochameau.

Fixes a new regression before it ships in 94. Approved for 94.0b8.

Attachment #9244342 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

The issue is also verified as fixed on Beta 94.0b8, under macOS 11, Win 11 x64 and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.