first element of html list is unnececarilly and reproducably newlined right before link, when preceded by TAB in html-source.

RESOLVED DUPLICATE of bug 100930

Status

()

Core
Layout
--
trivial
RESOLVED DUPLICATE of bug 100930
15 years ago
15 years ago

People

(Reporter: Guido Poschta, Assigned: Marc Attinasi)

Tracking

({testcase})

Trunk
x86
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2a) Gecko/20020910

Condition:
- a list in html using the <ul> and <li> tags
- items in list contain links
- items are indented using Tabs

Problem:
- right before the first link of the first item in the list,
a new line is started

START HTML-Code Snippet (replace /TAB/ by tab-sign)

<ul>
/TAB/<li>28.08.2002 - <a
HREF="intern/Wizard-Papier-Prototyp/wizard-papier-prototyp-020828.html">Papier-Prototypen</a>
ins Intern gelegt</li>
/TAB/<li>20.08.2002 - <a HREF="info" target="_blank">Info-Frameset</a> mit den
wichtigsten externen Links angelegt</li>
</ul>


Reproducible: Always

Steps to Reproduce:
1.open mozilla
2.launch above url

Actual Results:  
looks buggy as described

Expected Results:  
not insert a newline

will include snapshot.
(Reporter)

Comment 1

15 years ago
Created attachment 102241 [details]
snapshot of described unnececcary linebreak

Comment 2

15 years ago
Created attachment 102261 [details]
Testcase

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 100930 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Keywords: testcase
Resolution: --- → DUPLICATE

Comment 4

15 years ago
A list defines a new block (and therefore really cannot be part of a paragraph
with inline content, as in the code). New block level elements always begin
after the preceding block, which means Mozilla emulates a paragraph break after
the heading preceding the list. This is entirely correct.

If one wants a header belonging to the list, <dl><dt>header</dt><dd><ul><li>item
1</li><li>item 2></li> ... </ul></dd></dl> is the way to go.
You need to log in before you can comment on or make changes to this bug.