Closed Bug 1733684 Opened 8 months ago Closed 7 months ago

Migrate win10-64-source from AWS to Azure

Categories

(Testing :: General, task)

task

Tracking

(firefox-esr91 fixed, firefox95 fixed)

RESOLVED FIXED
95 Branch
Tracking Status
firefox-esr91 --- fixed
firefox95 --- fixed

People

(Reporter: masterwayz, Assigned: masterwayz)

References

(Regressed 1 open bug)

Details

Attachments

(2 files)

Depends on: 1733712
Assignee: nobody → michelle
Status: NEW → ASSIGNED
Depends on: 1735396

There were two failures:

  • One caused by subprocess.Popen(...) no longer liking having an
    env={} argument. I couldn't find this documented in the API docs or
    fixed in a future 3.9.x release, but it's workaround-able by not
    setting the redundant parameter.
  • One caused by unexpected characters appearing in a symlink test.
    However, since we shouldn't be leaning on symlinks on Windows, we skip
    the test accordingly.
Pushed by mhentges@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5f1461a4abcd
Resolve mozbuild test compatibility with Py 3.9.5 r=ahal
Pushed by michelle@masterwayz.nl:
https://hg.mozilla.org/integration/autoland/rev/3417336ac329
Move the win10-64-source jobs over to the new Win10 2004 Azure workers r=jmaher
Flags: needinfo?(michelle)
Keywords: leave-open
Depends on: 1736416
Pushed by michelle@masterwayz.nl:
https://hg.mozilla.org/integration/autoland/rev/ab16bb5e5985
Move the win10-64-source jobs over to the new Win10 2004 Azure workers r=jmaher
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Keywords: leave-open

(False alarm)

Status: REOPENED → RESOLVED
Closed: 7 months ago7 months ago
Resolution: --- → FIXED
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.