Closed Bug 1733704 Opened 4 months ago Closed 3 months ago

about:unloads Should Explain Why Some Fields Are Empty

Categories

(Firefox :: Tabbed Browser, defect)

Firefox 94
defect

Tracking

()

RESOLVED FIXED
95 Branch
Tracking Status
firefox94 --- wontfix
firefox95 --- fixed

People

(Reporter: haik, Assigned: toshi)

References

Details

Attachments

(2 files)

In about:unloads, some table cells are left blank and it's not explained why which might be confusing or appear buggy to users. We should fill in all cells of the table or explain in the text why some fields are empty. See screenshot for example.

See Also: → 1733939
Duplicate of this bug: 1733939
Blocks: 1587762
See Also: 17339391725257
Assignee: nobody → tkikuchi
Status: NEW → ASSIGNED
Pushed by tkikuchi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5baaf754b94b
Explain why some columns are empty in the table of about:unloads.  r=haik,fluent-reviewers,flod
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch

The patch landed in nightly and beta is affected.
:toshi, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(tkikuchi)

Comment on attachment 9244316 [details]
Bug 1733704 - Explain why some columns are empty in the table of about:unloads. r=haik

Beta/Release Uplift Approval Request

  • User impact if declined: Bug 1725257 added a new page about:unloads. Users may think having empty cells in the table in that page is a bug because of lack of explanation.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The patch changes only text resources used in about:unloads.
  • String changes made/needed: Yes
Flags: needinfo?(tkikuchi)
Attachment #9244316 - Flags: approval-mozilla-beta?

flod, are we good taking this on Beta or should it ride 94?

Flags: needinfo?(francesco.lodolo)

(In reply to Ryan VanderMeulen [:RyanVM] from comment #7)

flod, are we good taking this on Beta or should it ride 94?

Please let it ride the trains. I don't think this is exactly a largely used feature for now, and I would like to avoid unnecessary noise for 94.

Flags: needinfo?(francesco.lodolo)
Attachment #9244316 - Flags: approval-mozilla-beta? → approval-mozilla-beta-

Perhaps it's possible I'm misunderstanding this bug, but I'm on the latest Nightly on Windows and still have some blank cells in about:unloads.

(In reply to Caspy7 from comment #9)

Perhaps it's possible I'm misunderstanding this bug, but I'm on the latest Nightly on Windows and still have some blank cells in about:unloads.

The goal of this bug wasn't getting rid of empty cells, just to add an explanation, which now points to https://firefox-source-docs.mozilla.org/browser/tabunloader/

You need to log in before you can comment on or make changes to this bug.