AOL spamvertisement in bookmarks search results

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: jcm, Assigned: bugs)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

When performing a search in the bookmarks manager with the keyword "aol", false
results are returned. Mozilla 1.1 shows a bookmark that does not actually exist
in the bookmarks.html file, the bookmark in question leading to a "Free AOL"
promotion.

Reproducible: Always

Steps to Reproduce:
1.In browser, hit Control-B to bring up bookmarks manager
2.In bookmarks manager, hit Control-F to perform a search
3.Enter "aol" as the search keyword
4.Hit enter or click the Find button

Actual Results:  
Bookmark search results window appears and includes this result, which does not
actually exist in the bookmarks file:

Name        = Free AOL & Unlimited Internet
Location    = http://free.aol.com/tryaolfree/index.adp?159820
Keyword     = N/A
Description = N/A
Added       = 10/8/2002 7:11:02PM
Modified    = 10/8/2002 7:10:41PM

Note that the added and modified datetime stamps reflect when the search was
performed.

Expected Results:  
Mozilla should have performed a legitimate search of bookmarks, returning any
that matched the keyword "aol" in the description. In this case, NONE.

Have not yet tested to see if this behavior occurs in earlier versions of Mozilla.
Can not reproduce in Mozilla 1.1 for RedHat Linux 7.x (RPM install)

Comment 1

16 years ago
this probably came from n4 or n6 or n7, it's not in cvs.

try mozilla -ProfileManager, if create profile creates it then you can complain.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 2

16 years ago
Reopening, I think this is a dupe of either bug 123679 or bug 96789 (the latter
more specifically, though it's not clear if there really are two different
problems).

I see this behavior myself with 1.2a.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 3

16 years ago
Behavior does not originate from any Netscape installation, all Netscape trees
were removed long ago[1]. When upgrading from Mozilla 1.0 to 1.1 a full
uninstall was done, preserving soley the profile directory.

As suggested, created a new stock profile. Exact same behavior occured with
stock Mozilla 1.1 profile. :(

Full search of all files in profile does not reveal any match to "Free Aol" or
"free.aol.com" strings. This is NOT a case of a deleted bookmark appearing in
searches.

Tested Netscape 6.1 on a seperate system and it exhibits the same
spamvertisement behavior. The FishCam was a much nicer Easter Egg...

Note: Adjusted summary of bug to be slightly less sensational


[1] Well only from my PC of course, :)
Summary: AOL spamvertisement hidden in bookmarks search function → AOL spamvertisement in bookmarks search results

Comment 4

16 years ago
I think this is more likely a dupe of bug 165977.

Comment 5

16 years ago
Jeff, is the AOL link in your Internet Explorer bookmarks?  Just trying to
figure out where it's coming from--searching the mozilla source code doesn't
show the address either.

Regarding the memory cache, I thought I had tested this across mozilla loads. 
But in any case, the AOL bookmark has now been removed from my system, after
removing the AOL bookmark from both moz and IE and working on other things in
the interim.  Still seeing some other carryover from IE bookmarks (which were in
my profile, until I deleted them), and clearing the memory cache doesn't help.
(Reporter)

Comment 6

16 years ago
No AOL bookmark in IE bookmarks. I actually wiped all IE bookmarks and favorites
from the default install of IE 5.5 when first setting up system.

I'll do some more testing with Mozilla installs on other systems, I'm wondering
if it could be related to whether certain plugins have been installed...

Comment 7

16 years ago
Jeff - can you still reproduce this bug?

when you talked about removing old netscape installations, you didn't mention
profiles - does the bookmark exist in any old netscape/mozilla profiles?

if this isn't still happening, please resolve it as WORKSFORME. thanks.

Comment 8

16 years ago
I'm unable to reproduce this on Linux using 2002120705.
(Reporter)

Comment 9

16 years ago
I tested with Mozilla 1.2.1 and 1.3a under Windows2000 and found I could still
produce the same behavior, with some caveats:

  a) The AOL bookmark would appear when doing a bookmark search on the initial
     launch of Mozilla (i.e. just after installation had completed). After exiting
     and restarting Mozilla, the AOL bookmark would cease to appear when doing
     a search.

  b) With Mozilla 1.1 and 1.0 (again, Windows 2000), the bookmark will always
     appear.

Yes, I tried deleting all previous profiles. I've tested this with both my home
system and work system, which have substantially different hardware. And
obviously my work system doesn't have the same installation history as my home
system.

Upon further experimentation I found that I could get the behavior to appear
reliablly if I used the bookmarks file I had from Mozilla 1.1 before doing the
upgrade. Analysis of the bookmarks file finds no references to AOL nor any
obfscuated references. Due to the nature of some of my work bookmarks I can not
share the file but I will attempt to isolate the key factors from the file.

Note that I do NOT see this behavior under the Linux version of Mozilla. I have
not tried importing the bookmarks file to the Linux version yet.

Comment 10

16 years ago
From testing in 1.3, this behavior is a specific case of being able to retrieve
any Windows "Favorites" links in bookmarks search upon creation of a new
profile, despite the failed import of those favorites.  The behavior was
probably only visible while IE import was broken (see bug 176715).  

This is probably WFM now that the bookmarks branch has landed, but I don't
currently have a recent trunk build to make sure.
Depends on: 176715

Comment 11

16 years ago
Works for me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 12

16 years ago
What version did you test? Still exhibits in 1.4RC1

Comment 13

16 years ago
Jeff, when you create a new profile in RC1, do IE favorites successfully import?
 (Please add a test favorite if you still have none as mentioned in comment 6.)
 Do any other searches produce nonexistent results?  For example, "Customize
Links," an IE default favorite, or one of the other links created by
installation of AIM?
(Reporter)

Comment 14

16 years ago
Yes, with 1.4RC1 the IE favorites succesfully import. I actually have three
sites bookmarked under IE favorites now.

Yes, the search for "Customize Links" produced results that did not appear to exist.

What I finally realized was I had disabled the displaying of the "Links" folder
under IE Favorites, using the TweakUI control panel. This Links folder did
indeed contain the evil Free AOL link as well as several others.
After re-enabling the display of the Links folder in IE Favorites and then
happily nuking the same, Mozilla no longer displays bogus results when searching
for "AOL" in bookmarks.

Further testing confirmed that when Mozilla starts up, it silently caches the
contents of IE Favorites, and will display any of those favorites that matches a
search string during a Find Bookmarks. I had Mozilla and IE open at the same
time, added a new favorite to IE. Searching in Bookmarks in Mozilla did not
match the new favorite. I then quit IE and Mozilla, and restarted Mozilla.
Searching bookmarks now matched the newly added Favorite.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.