Closed Bug 1734118 Opened 2 months ago Closed 2 months ago

119.09 - 3.78% google-slides FirstVisualChange / twitter PerceptualSpeedIndex + 9 more (Linux, OSX, Windows) regression on Wed September 29 2021

Categories

(Core :: DOM: Content Processes, defect, P1)

Firefox 95
defect

Tracking

()

RESOLVED FIXED
95 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox92 --- unaffected
firefox93 --- unaffected
firefox94 + fixed
firefox95 + fixed

People

(Reporter: alexandrui, Assigned: smaug)

References

(Regression)

Details

(Keywords: perf, perf-alert, regression)

Perfherder has detected a browsertime performance regression from push 8f2f2cfb962094db37c4a08ca10c181000699930. As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

Ratio Test Platform Options Absolute values (old vs new)
119% google-slides FirstVisualChange macosx1015-64-shippable-qr fission warm webrender 366.67 -> 803.33
70% fandom loadtime macosx1015-64-shippable-qr fission warm webrender 522.50 -> 886.83
40% google-slides SpeedIndex macosx1015-64-shippable-qr fission warm webrender 689.79 -> 965.92
35% google-slides PerceptualSpeedIndex macosx1015-64-shippable-qr fission warm webrender 717.17 -> 971.00
12% twitter ContentfulSpeedIndex windows10-64-shippable-qr fission warm webrender 760.92 -> 849.25
11% google-slides dcf windows10-64-shippable-qr fission warm webrender 746.88 -> 831.33
10% google-slides dcf linux1804-64-shippable-qr fission warm webrender 776.02 -> 854.29
8% twitter SpeedIndex windows10-64-shippable-qr fission warm webrender 798.83 -> 863.75
5% twitter LastVisualChange windows10-64-shippable-qr fission warm webrender 1,396.62 -> 1,467.42
4% google-slides PerceptualSpeedIndex linux1804-64-shippable-qr cold fission webrender 1,017.83 -> 1,057.75
4% twitter PerceptualSpeedIndex windows10-64-shippable-qr fission warm webrender 571.46 -> 593.08

Improvements:

Ratio Test Platform Options Absolute values (old vs new)
69% wikipedia fcp linux1804-64-shippable-qr fission warm webrender 1,271.25 -> 393.12
52% amazon fcp macosx1014-64-shippable-qr fission warm webrender 583.12 -> 278.92
52% amazon fcp linux1804-64-shippable-qr fission warm webrender 447.58 -> 215.17
51% amazon fcp windows10-64-shippable-qr fission warm webrender 398.50 -> 194.42
50% wikipedia loadtime linux1804-64-shippable-qr fission warm webrender 1,474.17 -> 730.12
... ... ... ... ...
3% google-slides loadtime windows10-64-shippable-qr fission warm webrender 1,207.88 -> 1,166.75

Details of the alert can be found in the alert summary, including links to graphs and comparisons for each of the affected tests. Please follow our guide to handling regression bugs and let us know your plans within 3 business days, or the offending patch(es) will be backed out in accordance with our regression policy.

For more information on performance sheriffing please see our FAQ.

Flags: needinfo?(nika)
Flags: needinfo?(nika) → needinfo?(rjesup)
See Also: 1734046
Duplicate of this bug: 1734046

Tentatively assigning to Randell because we discussed this regression in yesterday's Fission meeting. I resolved bug 1734046 as a duplicate in favor of this bug.

Assignee: nobody → rjesup
Fission Milestone: --- → MVP
Whiteboard: fission-soft-blocker
Priority: -- → P1
Whiteboard: fission-soft-blocker
See Also: → 1734558

Resolving as fixed because Randell says Olli's imglib priority boost in bug 1734811 fixes this regression.

Status: NEW → RESOLVED
Closed: 2 months ago
Flags: needinfo?(rjesup)
Resolution: --- → FIXED
See Also: → 1734811
Assignee: rjesup → bugs
Depends on: 1734811
See Also: 1734811
Target Milestone: --- → 95 Branch

(In reply to Chris Peterson [:cpeterson] from comment #4)

Resolving as fixed because Randell says Olli's imglib priority boost in bug 1734811 fixes this regression.

Bug 1734811 comment 8 shows only a couple of improvements on Android (non-Fission), and nothing for google-slides, fandom, or twitter. Are we sure this should be marked as resolved?

Flags: needinfo?(cpeterson)

(In reply to Dave Hunt [:davehunt] [he/him] ⌚GMT from comment #5)

(In reply to Chris Peterson [:cpeterson] from comment #4)

Resolving as fixed because Randell says Olli's imglib priority boost in bug 1734811 fixes this regression.

Bug 1734811 comment 8 shows only a couple of improvements on Android (non-Fission), and nothing for google-slides, fandom, or twitter. Are we sure this should be marked as resolved?

I'll send this bug back to Fission triage for discussion.

Fission Milestone: MVP → ?
Flags: needinfo?(cpeterson)

Fission definitely got improved, it just happened through another bug because of process switching logic.
One can check AWFY numbers.

Fission Milestone: ? → ---
You need to log in before you can comment on or make changes to this bug.