Closed Bug 1734127 Opened 4 months ago Closed 4 months ago

There are extra characters added in the name of the selected theme if a colorway is clicked twice

Categories

(Firefox :: Messaging System, defect, P1)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
95 Branch
Iteration:
95.1 - Oct 4 - Oct 17
Tracking Status
firefox93 --- unaffected
firefox94 + verified
firefox95 --- verified

People

(Reporter: cmuntean, Assigned: pdahiya)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files)

[Affected Versions]:

  • Firefox Nightly 95.0a1 (Build ID: 20211004215121)
  • Firefox Beta 94.0b1 (Build ID: 20211004193346)

[Affected Platforms]:

  • Windows 10 x64
  • macOS 10.15.7
  • Linux Mint 20

[Steps to reproduce]:

  1. Open the latest Nightly/Beta build.
  2. Open a New Tab page and navigate to the "about:welcome" page.
  3. Navigate through Onboarding until the "Life in color" slide is displayed.
  4. Click on the first colorway (default themes).
  5. Observe the name of the theme.

[Expected results]:

  • The name is correctly displayed.

[Actual results]:

  • There are extra characters added in the theme name.

[Notes]:

  • The issue is reproducible for all colorways. The issue is more visible for the first colorway (default themes), since there are multiple characters added in the name and the buttons are pushed out from the circle area.
  • The issue is not reproducible for the Upgrade Spotlight modal.
  • Attached is a screen recording of the issue.

Issue most probably is fallout of stringify label on click of colorway https://searchfox.org/mozilla-central/source/browser/components/newtab/content-src/aboutwelcome/components/Colorways.jsx#105

Assigning myself to debug and fix thanks

Assignee: nobody → pdahiya
Priority: -- → P1

[Tracking Requested - why for this release]:MR2 new user onboarding fixes

Pushed by pdahiya@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e9df3bcdd149
Fix displayed colorways name inside variation circle r=Mardak
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
Iteration: --- → 95.1 - Oct 4 - Oct 17

I have verified this issue on the latest Nightly 95.0a1 build (Build ID: 20211006213819) on Windows 10 x64, macOS 10.15.7 and Linux Mint 20.

  • The name is correctly displayed if a colorway is clicked twice.

@Punam should we request a Beta uplift for this fix?

Flags: needinfo?(pdahiya)

Comment on attachment 9244410 [details]
Bug 1734127 - Fix displayed colorways name inside variation circle

Beta/Release Uplift Approval Request

  • User impact if declined: Colorway variation picker will show unwanted double quote characters and text
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: https://bugzilla.mozilla.org/show_bug.cgi?id=1734127#c0
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small UI fix verified in Nightly by QA
  • String changes made/needed: None
Flags: needinfo?(pdahiya)
Attachment #9244410 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9244410 [details]
Bug 1734127 - Fix displayed colorways name inside variation circle

Approved for 94.0b3.

Attachment #9244410 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

I have verified this issue on the latest Beta 94.0b3 candidate build (Build ID: 20211007185900) on Windows 10 x64, macOS 10.15.7 and Linux Mint 20.

  • The name is correctly displayed if a colorway is clicked twice.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.