Closed Bug 1734196 Opened 1 year ago Closed 1 year ago

Crash in [@ ffi_support::handle_map::ConcurrentHandleMap<T>::insert]

Categories

(Data Platform and Tools :: Glean: SDK, defect)

Unspecified
Android
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1733757

People

(Reporter: kbrosnan, Unassigned)

Details

(Keywords: crash)

Crash Data

Crash report: https://crash-stats.mozilla.org/report/index/43ab027b-cc35-407d-83be-3a8210211005

MOZ_CRASH Reason: Bug: next_index pointed at non-free list entry (or end of list)

Top 10 frames of crashing thread:

0 libxul.so RustMozCrash mozglue/static/rust/wrappers.cpp:18
1 libxul.so mozglue_static::panic_hook mozglue/static/rust/lib.rs:91
2 libxul.so core::ops::function::Fn::call library/core/src/ops/function.rs:70
3 libxul.so std::panicking::rust_panic_with_hook library/std/src/panicking.rs:626
4 libxul.so std::panicking::begin_panic::{{closure}} library/std/src/panicking.rs:542
5 libxul.so std::sys_common::backtrace::__rust_end_short_backtrace library/std/src/sys_common/backtrace.rs:141
6 libxul.so std::panicking::begin_panic library/std/src/panicking.rs:541
7 libxul.so ffi_support::handle_map::ConcurrentHandleMap<T>::insert third_party/rust/ffi-support/src/handle_map.rs:762
8 libxul.so glean_labeled_counter_metric_get third_party/rust/glean-ffi/src/labeled.rs:77
9 libjnidispatch.so libjnidispatch.so@0x10154 

I've had this crash twice today on my Galaxy S21 using the Twitter PWA via Fenix Nightly.

Component: mozglue → Glean: SDK
Product: Core → Data Platform and Tools

This is the same as bug 1733757.
Any chance we can get the associated crash data moved over there and close this as a dup?

Flags: needinfo?(kbrosnan)

Ah, it's as easy as pasting the crash signature into the crash field.

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(kbrosnan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1733757
You need to log in before you can comment on or make changes to this bug.