Closed Bug 1734359 Opened 4 months ago Closed 4 months ago

Make system toolbar dark on Win10 dark mode dialogs as appropriate.

Categories

(Core :: Widget: Win32, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
95 Branch
Tracking Status
firefox95 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We can use DWMWA_USE_IMMERSIVE_DARK_MODE for this.

This can be accomplished by the undocumented DWMWA_USE_IMMERSIVE_DARK_MODE.

You can test this by going to "Customize Toolbar" and checking "Title Bar", or
opening any native dialog like e.g. the profile creation window / the profile
manager / etc.

AWESOME

Blocks: dark-mode
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b94153cca1f7
Make system toolbar dark on windows dark mode. r=cmartin
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
Regressions: 1734658
Regressions: 1734661
Regressions: 1734668
Regressions: 1734690
Regressions: 1735064
Duplicate of this bug: 1607929
Type: defect → enhancement
No longer regressions: 1734690
Blocks: 1741900
Duplicate of this bug: 1674566
You need to log in before you can comment on or make changes to this bug.