[RFE] Cache Browser tool - for browsing Cache for files like Flash, Mov, etc and moving elsewhere

RESOLVED DUPLICATE of bug 66299

Status

SeaMonkey
General
--
enhancement
RESOLVED DUPLICATE of bug 66299
15 years ago
13 years ago

People

(Reporter: Martin Andersen, Assigned: asa)

Tracking

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.0.1) Gecko/20020823 Netscape/7.0
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.0.1) Gecko/20020823 Netscape/7.0

Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.0.1) Gecko/20020823 Netscape/7.0 

Since Netscape 7, I've switched over to it as my primary browser, although more
work needs to be done.  
One reason I sometimes still use Internet Explorer is because the Browser Cache
is easily accessible, with the files having their original names (except for
numbering in square brackets after their name), so it is easy to go to get a
graphic, a Flash file or movie (MOV, AVI, etc) which cannot be saved from the
browser.  Or just looking for something browsed previously. Netscape doesn't
allow for that at present.

Please consider a Cache Explorer tool, (perhaps listed under 'tools':
1. It should list the cache similar to Windows Temp Internet Files dir or other
3rd party Cache Explorers that allow browsing of the Cache, with various columns
like filename, size, type, last accessed, website URL etc, sorted according to
which column header you click, but defaulting to Last Accessed.  Which columns
appear should be customisable too.
2. Make cached HTML files browsable in Netscape, like an offline browser, and
ability to open image/other files in appropriate helper applications, if not the
browser.
3. This Cache Explorer tool should have file management tools for copying files
to other folders with the file's actual name. Possibly even with the option of
copying the site structure (visited image galleries, whatever, they often have
generic names like 'img01.jpg' and would overwrite each other if placed in the
same folder).  This part ties in with various other Feature Requests for offline
browsing/leeching, but is not a duplicate.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
This could probably be added to about:cache....

Comment 2

15 years ago
dupe of bug 66299 ?

And we can use bug 99817 too ...

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 66299 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.